Bug 1119313 - [staypuft] cisco_nexus plugin parameter missing, causing deployments to fail
Summary: [staypuft] cisco_nexus plugin parameter missing, causing deployments to fail
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ruby193-rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 13:42 UTC by Joe Talerico
Modified: 2014-09-08 05:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-05 17:14:27 UTC


Attachments (Terms of Use)

Description Joe Talerico 2014-07-14 13:42:44 UTC
Description of problem:
Staypuft UI removed the Cisco plugin, which is now causing non-ha (GRE,VXLAN, and FLAT) deployments to fail 

[root@e4115bb80110 ~]# puppet agent -t
Info: Retrieving plugin
Info: Loading facts in /var/lib/puppet/lib/facter/staging_http_get.rb
Info: Loading facts in /var/lib/puppet/lib/facter/kvm_capable.rb
Info: Loading facts in /var/lib/puppet/lib/facter/ip6tables_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/galera_bootstrap_ok.rb
Info: Loading facts in /var/lib/puppet/lib/facter/hamysql_active_node.rb
Info: Loading facts in /var/lib/puppet/lib/facter/puppet_vardirtmp.rb
Info: Loading facts in /var/lib/puppet/lib/facter/gluster_host.rb
Info: Loading facts in /var/lib/puppet/lib/facter/staging_windir.rb
Info: Loading facts in /var/lib/puppet/lib/facter/gluster_property.rb
Info: Loading facts in /var/lib/puppet/lib/facter/facter_dot_d.rb
Info: Loading facts in /var/lib/puppet/lib/facter/ipa_client_configured.rb
Info: Loading facts in /var/lib/puppet/lib/facter/puppet_bug.rb
Info: Loading facts in /var/lib/puppet/lib/facter/rabbitmq_erlang_cookie.rb
Info: Loading facts in /var/lib/puppet/lib/facter/root_home.rb
Info: Loading facts in /var/lib/puppet/lib/facter/gluster_fsuuid.rb
Info: Loading facts in /var/lib/puppet/lib/facter/gluster_vrrp.rb
Info: Loading facts in /var/lib/puppet/lib/facter/gluster_fsm.rb
Info: Loading facts in /var/lib/puppet/lib/facter/gluster_ports.rb
Info: Loading facts in /var/lib/puppet/lib/facter/puppet_vardir.rb
Info: Loading facts in /var/lib/puppet/lib/facter/pe_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/gluster_uuid.rb
Info: Loading facts in /var/lib/puppet/lib/facter/iptables_persistent_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/iptables_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/gluster_version.rb
Info: Loading facts in /var/lib/puppet/lib/facter/gluster_bricks.rb
Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Received incomplete information - no value provided for parameter nexus_config on node e4115bb80110.perf.lab.eng.bos.redhat.com
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

Comment 2 Mike Burns 2014-08-05 17:14:27 UTC
Can't reproduce this anymore.  Please re-open if it reproduces in the future


Note You need to log in before you can comment on or make changes to this bug.