Bug 1119371 - Cannot use down arrow key when there's empty value in drop-down.
Summary: Cannot use down arrow key when there's empty value in drop-down.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.6.0
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard: ux
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 15:46 UTC by Gilad Chaplik
Modified: 2016-02-10 19:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-22 14:57:46 UTC
oVirt Team: UX


Attachments (Terms of Use)

Description Gilad Chaplik 2014-07-14 15:46:28 UTC
Description of problem:
when there's an empty value in drop-down, and you want to fill it in using keyboard, normal behavior is to use 'down arrow' key.

but since the empty value is last in the drop down list, only up key is acceptable.

Version-Release number of selected component (if applicable):
master (July 14th).

How reproducible:
100%

Steps to Reproduce:
1. open new cluster
2. focus/goto/put marker /on CPU Type (using tabs)
3. press down arrow key 

Actual results:
nothing happens

Expected results:
should select first

Additional info:
Although I found it only for that, should be solved as part of infra.

Comment 1 Einav Cohen 2014-07-22 14:57:46 UTC
this isn't related to the value in the drop-down being empty: the items in the drop-down are ordered; if you happen to be on the last item (empty or not), you cannot scroll "down" anymore; if you happen to be on the first item (empty or not), you cannot scroll "up" anymore. this is the built-in, normal drop-down behavior, and it should not be messed with. 
I don't recall any other behavior in any other drop-down that I've seen. 
if there is a specific problem in a specific drop down, and it makes sense that an empty item should be first, rather than last - that specific drop-down should change.


Note You need to log in before you can comment on or make changes to this bug.