Bug 1119383 - Exception instead of error when only /boot/efi partition created
Summary: Exception instead of error when only /boot/efi partition created
Keywords:
Status: CLOSED DUPLICATE of bug 991620
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 16:11 UTC by Konstantin Volkov
Modified: 2014-07-18 00:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-18 00:57:57 UTC


Attachments (Terms of Use)

Description Konstantin Volkov 2014-07-14 16:11:07 UTC
Description of problem:

Exception instead of error when only /boot/efi partition created

Version-Release number of selected component (if applicable):
anaconda 13.21.215

How reproducible:
100%

Steps to Reproduce:
1. Start clean installation on EFI-capable system
2. Select Custom Partition Layout
3. Create just /boot/efi partition
4. Next

Actual results:
---
15:49:11,828 CRITICAL: anaconda 13.21.215 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/platform.py", line 296, in checkBootRequest
    if boot_device.size > 2*1024*1024:
  File "/usr/lib/anaconda/storage/__init__.py", line 1134, in sanityCheck
    errors.extend(self.anaconda.platform.checkBootRequest(boot))
  File "/usr/lib/anaconda/iw/partition_gui.py", line 850, in getNext
    (errors, warnings) = self.storage.sanityCheck()
  File "/usr/lib/anaconda/gui.py", line 1485, in nextClicked
    rc = self.currentWindow.getNext ()
AttributeError: 'NoneType' object has no attribute 'size'
---

Expected results:
Error "No / partition created"

Additional info:

The next patch fix it:

---
--- platform.py.orig<-->2014-07-14 19:51:23.789489092 +0400
+++ platform.py>2014-07-14 19:54:05.454488667 +0400
@@ -293,7 +293,7 @@
             errors += boot_errors
.
         # Limit /boot to 2TB
-        if boot_device.size > 2*1024*1024:
+        if boot_device and boot_device.size > 2*1024*1024:
             # If there is no /boot, ask for one
             if boot_device.format.mountpoint == "/":
                 errors.append(_("/boot must be less than 2TB. Shrink / or create a separate /boot partition."))
---

Please, fix.

Comment 2 Brian Lane 2014-07-18 00:57:57 UTC
This is fixed by the fix for bug 991620

*** This bug has been marked as a duplicate of bug 991620 ***


Note You need to log in before you can comment on or make changes to this bug.