Bug 1119419 - openshift.sh support for CONF_JBOSSEAP_BETA_REPO
Summary: openshift.sh support for CONF_JBOSSEAP_BETA_REPO
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
: ---
Assignee: Brenton Leanhardt
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 18:06 UTC by Brenton Leanhardt
Modified: 2014-09-18 15:18 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-12 00:39:09 UTC


Attachments (Terms of Use)

Description Brenton Leanhardt 2014-07-14 18:06:58 UTC
Description of problem:

From time to we need to test pre-released versions of JBoss EAP.  We have support for setting CONF_JBOSS_REPO_BASE but that affects the JBoss EWS repository as well.  We'd like a setting that allows for an extra repository to be configured and leave the base JBoss related repository configuration in place.

Comment 1 Brenton Leanhardt 2014-07-14 18:13:37 UTC
https://github.com/openshift/openshift-extras/pull/400

Comment 2 John W. Lamb 2014-07-30 19:16:37 UTC
QE, please test and merge: https://github.com/openshift/openshift-extras/pull/423/

Comment 3 John W. Lamb 2014-07-30 19:19:28 UTC
(In reply to John W. Lamb from comment #2)
> QE, please test and merge:
> https://github.com/openshift/openshift-extras/pull/423/

Some background; this PR adds 4 new optional conf vars to openshift.sh:
 * CONF_RHEL_EXTRA_REPO
 * CONF_JBOSSEAP_EXTRA_REPO
 * CONF_JBOSSEWS_EXTRA_REPO
 * CONF_RHSCL_EXTRA_REPO

These variables are documented in the openshift.sh script comments

Thanks!

Comment 4 Johnny Liu 2014-07-31 09:08:55 UTC
Currently these 4 conf vars only work with yum install method, do not work with rhsm and rhn, is it possible to make it work with rhsm and rhn, just like ose extra repo?

Comment 5 John W. Lamb 2014-08-01 21:22:22 UTC
(In reply to Johnny Liu from comment #4)
> Currently these 4 conf vars only work with yum install method, do not work
> with rhsm and rhn, is it possible to make it work with rhsm and rhn, just
> like ose extra repo?

The PR has been updated; the EXTRA repos should now be applied regardless which install method is used.

Comment 6 Anping Li 2014-08-04 11:18:01 UTC
The extra conf works with rhn and rhsm now. we still need to fix two issue.
1) configure_extra_repos can't be called by yum method. 
2) Duplicate repo file were created for rhn and rhsm. For example:
-rw-r--r--.  1 root root  250 Aug  4 07:01 openshift-client_tools-extra.repo
-rw-r--r--.  1 root root  250 Aug  4 06:59 openshift-client_tools-extra.repo.backup_20140804-0

Comment 7 John W. Lamb 2014-08-04 13:36:58 UTC
(In reply to Anping Li from comment #6)
> The extra conf works with rhn and rhsm now. we still need to fix two issue.
> 1) configure_extra_repos can't be called by yum method. 
> 2) Duplicate repo file were created for rhn and rhsm. For example:
> -rw-r--r--.  1 root root  250 Aug  4 07:01 openshift-client_tools-extra.repo
> -rw-r--r--.  1 root root  250 Aug  4 06:59
> openshift-client_tools-extra.repo.backup_20140804-0

I'll fix 1) today

2) is caused by oo-admin-yum-validator; I'll have to actually think about how best to address it. Maybe oo-admin-yum-validator should get an option like --no-backups

Comment 8 Luke Meyer 2014-08-04 16:48:10 UTC
(In reply to Anping Li from comment #6)

> 2) Duplicate repo file were created for rhn and rhsm. For example:
> -rw-r--r--.  1 root root  250 Aug  4 07:01 openshift-client_tools-extra.repo
> -rw-r--r--.  1 root root  250 Aug  4 06:59
> openshift-client_tools-extra.repo.backup_20140804-0

This isn't really a problem, just looks kinda strange.

You *do* need to ensure, however, that the "extra" repos aren't prioritized into insignificance by oo-admin-yum-validator. I think it might make sense to create them twice: once before doing anything else (so that openshift-enterprise-release and dependencies are in place from the start) and once after all "normal" repo config (to fix the fact they've been deprioritized). Unless you can keep them from being deprioritized via o-a-y-v.

Comment 9 John W. Lamb 2014-08-04 17:13:17 UTC
(In reply to Luke Meyer from comment #8)
> (In reply to Anping Li from comment #6)
> 
> > 2) Duplicate repo file were created for rhn and rhsm. For example:
> > -rw-r--r--.  1 root root  250 Aug  4 07:01 openshift-client_tools-extra.repo
> > -rw-r--r--.  1 root root  250 Aug  4 06:59
> > openshift-client_tools-extra.repo.backup_20140804-0
> 
> This isn't really a problem, just looks kinda strange.
> 
> You *do* need to ensure, however, that the "extra" repos aren't prioritized
> into insignificance by oo-admin-yum-validator. I think it might make sense
> to create them twice: once before doing anything else (so that
> openshift-enterprise-release and dependencies are in place from the start)
> and once after all "normal" repo config (to fix the fact they've been
> deprioritized). Unless you can keep them from being deprioritized via
> o-a-y-v.

They are created twice; in configure_subscription, configure_extra_repos gets called before and after the o-a-y-v run, just like configure_ose_yum_repos.

Comment 10 John W. Lamb 2014-08-04 19:11:08 UTC
(In reply to Anping Li from comment #6)
> The extra conf works with rhn and rhsm now. we still need to fix two issue.
> 1) configure_extra_repos can't be called by yum method. 
> 2) Duplicate repo file were created for rhn and rhsm. For example:
> -rw-r--r--.  1 root root  250 Aug  4 07:01 openshift-client_tools-extra.repo
> -rw-r--r--.  1 root root  250 Aug  4 06:59
> openshift-client_tools-extra.repo.backup_20140804-0

https://github.com/openshift/openshift-extras/pull/423/ has been updated to address 1)

2) is kind of an issue, but it's non-blocking and a truly better way to do this isn't obvious at the moment.

Comment 11 Anping Li 2014-08-05 09:08:21 UTC
Verified and pass on  OSE 1.2z/2014-07-30, OSE 2.0z/2014-07-30.1 and OSE 2.1.z/2014-08-04.1/.
All extra repo can be configured by openshift.sh using rhn,rhsm,yum method. openshift can be installed with these repos.


Note You need to log in before you can comment on or make changes to this bug.