Bug 1119423 - rpmlint dictionary shows warning: imapd-> imaged
Summary: rpmlint dictionary shows warning: imapd-> imaged
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmlint
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 18:28 UTC by Avesh Agarwal
Modified: 2014-07-17 08:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-14 20:44:51 UTC


Attachments (Terms of Use)

Description Avesh Agarwal 2014-07-14 18:28:45 UTC
Description of problem:
rpmlint dictionary shows warning: imapd-> imaged 

imapd is acronym for Internet Message Access Protocol daemon.  

Version-Release number of selected component (if applicable):
rpmlint-1.5-12.fc20.noarch

How reproducible:
always

Steps to Reproduce:
1. take any srpm like stunnel that impad in its %description tag
2. run rpmlin 
3. it shows false warning: W: spelling-error %description -l en_US imapd -> imaged

Actual results:
it shows false warning: W: spelling-error %description -l en_US imapd -> imaged

Expected results:
No warning

Additional info:

Comment 1 Tom "spot" Callaway 2014-07-14 20:44:51 UTC
This is because "imapd" is not an english word. It's not a false warning, its just safe to ignore.

Comment 2 Ville Skyttä 2014-07-17 08:25:17 UTC
BTW it's not rpmlint's dictionary in action, it's whatever enchant ends up using (most likely hunspell-en).


Note You need to log in before you can comment on or make changes to this bug.