Bug 111949 - Need isos pushed to to RHN for the RHEL 3 Update 1 GA
Need isos pushed to to RHN for the RHEL 3 Update 1 GA
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris MacLeod
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 16:28 EST by Tim Powers
Modified: 2007-04-18 13:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 14:17:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL 3 Channel names / Labels (10.28 KB, text/plain)
2003-12-12 11:36 EST, Chris MacLeod
no flags Details
mappings spreadsheet (12.02 KB, text/plain)
2003-12-12 14:12 EST, Tim Powers
no flags Details
updated mappings spreadsheet (11.99 KB, text/plain)
2003-12-12 15:01 EST, dff
no flags Details
iso upload list for RHEL 3 U1 (3.03 KB, text/plain)
2004-01-14 13:04 EST, Tim Powers
no flags Details
new iso upload list for U1 (2.66 KB, text/plain)
2004-01-14 14:12 EST, Tim Powers
no flags Details
Updated iso mapping file for GA of RHEL3 U1 (5.13 KB, text/plain)
2004-01-15 10:58 EST, Chris MacLeod
no flags Details
iso mapping rhel 3 u1 (9.60 KB, text/plain)
2004-01-15 12:50 EST, Chris MacLeod
no flags Details

  None (edit)
Description Tim Powers 2003-12-11 16:28:12 EST
The following isos and signed MD5SUM files need to be pushed to RHN
for the U1 beta (I've already taken care of pushing the packages).:

i386 AS:
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/i386/as/ftp-isos/RHEL3-U1-Beta-RC-re1211.0-i386-as-disc1-ftp.iso
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/i386/as/ftp-isos/MD5SUM

i386 ES:
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/i386/es/ftp-isos/RHEL3-U1-Beta-RC-re1211.0-i386-es-disc1-ftp.iso
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/i386/es/ftp-isos/MD5SUM

i386 WS:
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/i386/ws/ftp-isos/RHEL3-U1-Beta-RC-re1211.0-i386-ws-disc1-ftp.iso
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/i386/ws/ftp-isos/MD5SUM

ia64 AS:
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/ia64/as/ftp-isos/RHEL3-U1-Beta-RC-re1211.0-ia64-as-disc1-ftp.iso
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/ia64/as/ftp-isos/MD5SUM

ia64 WS:
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/ia64/ws/ftp-isos/RHEL3-U1-Beta-RC-re1211.0-ia64-ws-disc1-ftp.iso
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/ia64/ws/ftp-isos/MD5SUM

ppc AS:
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/ppc/as/ftp-isos/RHEL3-U1-Beta-RC-re1211.0-ppc-as-disc1-ftp.iso
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/ppc/as/ftp-isos/MD5SUM

s390 AS:
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/s390/as/ftp-isos/RHEL3-U1-Beta-RC-re1211.0-s390-as-disc1-ftp.iso
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/s390/as/ftp-isos/MD5SUM

s390x AS:
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/s390x/as/ftp-isos/RHEL3-U1-Beta-RC-re1211.0-s390x-as-disc1-ftp.iso
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/s390x/as/ftp-isos/MD5SUM

x86_64 AS:
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/x86_64/as/ftp-isos/RHEL3-U1-Beta-RC-re1211.0-x86_64-as-disc1-ftp.iso
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/x86_64/as/ftp-isos/MD5SUM

x86_64 WS:
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/x86_64/ws/ftp-isos/RHEL3-U1-Beta-RC-re1211.0-x86_64-ws-disc1-ftp.iso
/mnt/redhat-scratch/RHEL3-U1-Beta-RC-re1211.0/x86_64/ws/ftp-isos/MD5SUM
Comment 1 Chris MacLeod 2003-12-12 11:36:08 EST
Created attachment 96496 [details]
RHEL 3 Channel names / Labels

This is the channel list for rhel3 including the beta channels.  Tim Powers,
Dff, and Dmcgrath have been shown a copy.  If there are errors or ommisions
feel free to edit and reattach.
Comment 2 Tim Powers 2003-12-12 12:24:54 EST
We need U1 beta "extras" channels for the other arches/variants as
well as ppc. Note that the other arches won't require isos to be
uploaded since only the ppc iso is changing.
Comment 3 Tim Powers 2003-12-12 14:12:32 EST
Created attachment 96500 [details]
mappings spreadsheet

Updated spreadsheet with the extras channels
Comment 4 dff 2003-12-12 15:01:21 EST
Created attachment 96501 [details]
updated mappings spreadsheet

Minor updates to channel names:
 * 'Beta Updates' not 'Beta Update 1' so that it doesn't have to change for U2
 * Shorten to i/pSeries and fix truncation

Neither is critical.
Comment 5 dff 2003-12-12 15:11:16 EST
To reiterate, so everyone is on the same page, this is how the world
should look for Update 1:

VISIBLE CHANNELS (given the proper entitlement):

Red Hat Enterprise Linux AS (v. 3 for x86)
- Red Hat Enterprise Linux AS (v. 3 for x86) Extras
- Red Hat Developer Suite (for AS x86)
- Red Hat Cluster Suite (for AS x86)
- Red Hat Enterprise Linux AS (v. 3 for x86) Beta Updates
- Red Hat Enterprise Linux AS (v. 3 for x86) Extras Beta
- Red Hat Developer Suite (for AS x86) Beta Updates
- Red Hat Cluster Suite (for AS x86) Beta Updates

Red Hat Enterprise Linux ES (v. 3 for x86)
- Red Hat Enterprise Linux ES (v. 3 for x86) Extras
- Red Hat Developer Suite (for ES x86)
- Red Hat Cluster Suite (for ES x86)
- Red Hat Enterprise Linux ES (v. 3 for x86) Beta Updates
- Red Hat Enterprise Linux ES (v. 3 for x86) Extras Beta
- Red Hat Developer Suite (for ES x86) Beta Updates
- Red Hat Cluster Suite (for ES x86) Beta Updates

Red Hat Enterprise Linux WS (v. 3 for x86)
- Red Hat Enterprise Linux WS (v. 3 for x86) Extras
- Red Hat Developer Suite (for WS x86)
- Red Hat Enterprise Linux WS (v. 3 for x86) Beta Updates
- Red Hat Enterprise Linux WS (v. 3 for x86) Extras Beta
- Red Hat Developer Suite (for WS x86) Beta Updates

Red Hat Enterprise Linux AS (v. 3 for Itanium)
- Red Hat Enterprise Linux AS (v. 3 for Itanium) Extras
- Red Hat Enterprise Linux AS (v. 3 for Itanium) Beta Updates
- Red Hat Enterprise Linux AS (v. 3 for Itanium) Extras Beta

Red Hat Enterprise Linux ES (v. 3 for Itanium)
- Red Hat Enterprise Linux ES (v. 3 for Itanium) Extras
- Red Hat Enterprise Linux ES (v. 3 for Itanium) Beta Updates
- Red Hat Enterprise Linux ES (v. 3 for Itanium) Extras Beta
** But NOTE -- we are not selling RHEL ES for Itanium currently

Red Hat Enterprise Linux WS (v. 3 for Itanium)
- Red Hat Enterprise Linux WS (v. 3 for Itanium) Extras
- Red Hat Enterprise Linux WS (v. 3 for Itanium) Beta Updates
- Red Hat Enterprise Linux WS (v. 3 for Itanium) Extras Beta

Red Hat Enterprise Linux AS (v. 3 for AMD64)
- Red Hat Enterprise Linux AS (v. 3 for AMD64) Extras
- Red Hat Enterprise Linux AS (v. 3 for AMD64) Beta Updates
- Red Hat Enterprise Linux AS (v. 3 for AMD64) Extras Beta

Red Hat Enterprise Linux ES (v. 3 for AMD64)
- Red Hat Enterprise Linux ES (v. 3 for AMD64) Extras
- Red Hat Enterprise Linux ES (v. 3 for AMD64) Beta Updates
- Red Hat Enterprise Linux ES (v. 3 for AMD64) Extras Beta
** But NOTE -- we are not selling RHEL ES for AMD64 currently

Red Hat Enterprise Linux WS (v. 3 for AMD64)
- Red Hat Enterprise Linux WS (v. 3 for AMD64) Extras
- Red Hat Enterprise Linux WS (v. 3 for AMD64) Beta Updates
- Red Hat Enterprise Linux WS (v. 3 for AMD64) Extras Beta

Red Hat Enterprise Linux AS (v. 3 for iSeries and pSeries)
- Red Hat Enterprise Linux AS (v. 3 for i/pSeries) Extras
- Red Hat Enterprise Linux AS (v. 3 for i/pSeries) Beta Updates
- Red Hat Enterprise Linux AS (v. 3 for i/pSeries) Extras Beta

Red Hat Enterprise Linux AS (v. 3 for S/390)
- Red Hat Enterprise Linux AS (v. 3 for S/390) Extras
- Red Hat Enterprise Linux AS (v. 3 for S/390) Beta Updates
- Red Hat Enterprise Linux AS (v. 3 for S/390) Extras Beta

Red Hat Enterprise Linux AS (v. 3 for zSeries)
- Red Hat Enterprise Linux AS (v. 3 for zSeries) Extras
- Red Hat Enterprise Linux AS (v. 3 for zSeries) Beta Updates
- Red Hat Enterprise Linux AS (v. 3 for zSeries) Extras Beta

INVISIBLE CHANNELS (to everyone):

These ones should not be visible and don't need to be populated.

Not visible because we're currently not using the 'Interim channels':
- Red Hat Enterprise Linux AS (v. 3 for x86) Interim Updates
- Red Hat Enterprise Linux ES (v. 3 for x86) Interim Updates
- Red Hat Enterprise Linux WS (v. 3 for x86) Interim Updates
- Red Hat Enterprise Linux AS (v. 3 for Itanium) Interim Updates
- Red Hat Enterprise Linux ES (v. 3 for Itanium) Interim Updates
- Red Hat Enterprise Linux WS (v. 3 for Itanium) Interim Updates
- Red Hat Enterprise Linux AS (v. 3 for AMD64) Interim Updates
- Red Hat Enterprise Linux ES (v. 3 for AMD64) Interim Updates
- Red Hat Enterprise Linux WS (v. 3 for AMD64) Interim Updates
- Red Hat Enterprise Linux AS (v. 3 for i/pSeries) Interim Updates
- Red Hat Enterprise Linux AS (v. 3 for S/390) Interim Updates
- Red Hat Enterprise Linux AS (v. 3 for zSeries) Interim Updates

Not visible because we're not launching Developer Suite on non-x86
platforms until Update 2 earliest, _not_ at Update 1, even though
there are trees and isos for some of these:
- Red Hat Developer Suite (for AS Itanium)
- Red Hat Developer Suite (for ES Itanium)
- Red Hat Developer Suite (for WS Itanium)
- Red Hat Developer Suite (for AS AMD64)
- Red Hat Developer Suite (for AS AMD64) Beta Updates
- Red Hat Developer Suite (for ES AMD64)
- Red Hat Developer Suite (for ES AMD64) Beta Updates
- Red Hat Developer Suite (for WS AMD64)
- Red Hat Developer Suite (for WS AMD64) Beta Updates
- Red Hat Developer Suite (for AS iSeries and pSeries)
- Red Hat Developer Suite (for AS iSeries and pSeries) Beta
Comment 6 Tim Powers 2003-12-12 15:15:48 EST
Great. Thanks for the update on the devsuite channels.

Tim
Comment 7 Tim Powers 2003-12-12 15:30:26 EST
Note that the ppc extras CD isos shouldn't be pushed yet, just staged.
Comment 8 Peter Jones 2003-12-12 17:31:40 EST
Don, when you say "given the proper entitlement", what are you
expecting here?  Are you expecting that when we push this live, all
rh-advanced-server customers should get rh-advanced-server-beta as
well?  Are there specific products that this should be associated
with, or is it really ALL AS/WS/ES/etc that we have -beta channels for?
Comment 9 dff 2003-12-12 17:40:34 EST
<dff> pjones: i think the simplest way to put it is..
<dff> each beta channel corresponds to non-beta channel
<pjones> dff: yeah, got that.
<dff> and the beta channels should be accessible to exactly the same
people that have access to the non-beta channel
<pjones> ok.
<pjones> That's the question.
<pjones> So everybody who has non-beta gets beta.
<dff> yep.  if you have x86 AS and x86 AS extras, you get x86 AS beta
and x86 AS extras beta
<dff> and so on
Comment 10 Tim Powers 2003-12-12 19:38:59 EST
I have checked the disc1 isos and they all appear to be sane (md5sums
match for what's listed on the webpages and what we have locally, and
the downloads from rhn match as well). The original gold isos have the
proper md5sums associated with them ojn the webpage.

We still need the extras channels created on production so I can chuck
 packages up there.
Comment 11 Chris MacLeod 2003-12-13 10:59:30 EST
I have run the csv in production to create the new channels that were
added later this week. (extras stuff).   Hardlink stuff is running in
QA, when it's finished I'll sync to production and make the hard links
for the source isos.  I'll have it all ready and staged for monday
morning.
Comment 12 Tim Powers 2003-12-13 15:43:03 EST
Thanks Chris. The extras packages are now staged in production.
Comment 13 Chris MacLeod 2003-12-14 21:52:05 EST
All isos are now staged in production.  Including hardlinks to the
source isos as well.  So isos in general are ready for switch flipping
tomorrow morning.
Comment 14 Chris MacLeod 2003-12-15 09:50:34 EST
All isos (src and binary) have been successfully pushed into
production.  Once the product mappings are finished they should show
up as in QA.
Comment 15 Tim Powers 2003-12-15 12:24:23 EST
Additional isos for i386 RHCS, i386 RHDS, and ppc Extras are here to
stage (but not release just yet):

i386 RHDS U1 beta:
/mnt/redhat-scratch/RHEL3-RHDS-U1-re1205.0/i386/ftp-isos/RHEL3-RHDS-U1-re1205.0-i386-ftp.iso

i386 RHCS U1 beta:
/mnt/redhat-scratch/RHEL3-RHCS-U1-re1213.0/i386/ftp-isos/RHEL3-RHCS-U1-re1213.0-i386-ftp.iso

ppc Extras U1 beta:
/mnt/redhat-scratch/RHEL3-LACD-U1-Beta-ppc-re1211.0/ppc/ftp-isos/RHEL3-LACD-U1-Beta-ppc-re1211.0-ppc-ftp.iso
Comment 16 Tim Powers 2003-12-19 14:27:52 EST
I have updated isos for the RHCS U1 beta available. The following iso
should be used instead of the previous iso I posted for RHCS:

/mnt/redhat-scratch/RHEL3-RHCS-U1-re1217.0/i386/ftp-isos/RHEL3-RHCS-U1-re1217.0-i386-ftp.iso
Comment 17 dff 2004-01-13 17:01:26 EST
Reopening bug that was used for U1 beta to cover U1 GA as well...

We are currently on track to release the final RHEL 3 Update 1 ISOs
for GA on Thursday, 1/15.  

The packages will be released using the errata tool.  We need RHN's
help to (a) post the ISOs and (b) help if the errata pushing breaks.
Comment 18 Tim Powers 2004-01-14 13:04:24 EST
Created attachment 96983 [details]
iso upload list for RHEL 3 U1

The isos listed in the attachment are for the RHEL 3 U1 push tomorrow. This
format should be scriptable.

MD5SUM files are available in the dir each of the isos are in.
Comment 19 Tim Powers 2004-01-14 14:12:04 EST
Created attachment 96986 [details]
new iso upload list for U1

new iso upload list for U1. Only difference is that the iso filenames have been
cleaned up. File contents are identical.
Comment 20 Chris MacLeod 2004-01-15 10:58:02 EST
Created attachment 97031 [details]
Updated iso mapping file for GA of RHEL3 U1

Mapping file for iso upload.  Please verify the category names as well as the
disc names.
Comment 21 Chris MacLeod 2004-01-15 12:50:45 EST
Created attachment 97035 [details]
iso mapping rhel 3 u1

updated with src files and additional disks for missing arches.
Comment 22 Tim Powers 2004-01-15 20:19:40 EST
Updated isos for RHCS:

rhel-i386-as-3-cluster:/mnt/redhat-scratch/RHEL3-U1-RC-RHCS-re0115.1/i386/ftp-isos/rhel-3-U1-rhcs-i386.iso
rhel-i386-es-3-cluster:/mnt/redhat-scratch/RHEL3-U1-RC-RHCS-re0115.1/i386/ftp-isos/rhel-3-U1-rhcs-i386.iso

Note You need to log in before you can comment on or make changes to this bug.