Bug 1119614 - Default dist cache sometimes boot as local cache
Summary: Default dist cache sometimes boot as local cache
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Grid 6
Classification: JBoss
Component: Server
Version: 6.2.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Tristan Tarrant
QA Contact: Martin Gencur
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 07:03 UTC by Takayoshi Kimura
Modified: 2018-12-09 18:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-26 14:25:39 UTC
Type: Bug


Attachments (Terms of Use)
Config and logs when reproduced (3.81 MB, application/zip)
2014-07-15 07:14 UTC, Takayoshi Kimura
no flags Details

Description Takayoshi Kimura 2014-07-15 07:03:14 UTC
When we have large # of caches defined in client server mode, sometimes default cache boot as local cache although it's defined as dist cache in configuration file. It only happens with default cache.

Looks like a concurrency issue at init phase in infinispan subsystem.

log:

15:33:13,273 TRACE [org.infinispan.jmx.JmxUtil] (MSC service thread 1-4) Registered org.infinispan.jmx.ResourceDMBean@66f12493 under jboss.infinispan:type=Cache,name="0000popopo0000Cache(local)",manager="clustered",component=Activation

config:

<cache-container name="clustered" default-cache="0000popopo0000Cache" statistics="true">
  <distributed-cache name="0000popopo0000Cache" owners="2" segments="20" mode="SYNC" remote-timeout="30000" start="EAGER">
    <locking isolation="READ_COMMITTED" striping="false" acquire-timeout="30000" concurrency-level="1000"/>
    <transaction mode="NONE"/>
  </distributed-cache>

Comment 2 Takayoshi Kimura 2014-07-15 07:14:03 UTC
Created attachment 918068 [details]
Config and logs when reproduced

Comment 3 Takayoshi Kimura 2014-07-15 07:19:23 UTC
This issue occurs roughly once per 50 tries, with 250 cache defs.


Note You need to log in before you can comment on or make changes to this bug.