Bug 111963 - TUX not implemented in this kernel
TUX not implemented in this kernel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: tux (Show other bugs)
3.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Ingo Molnar
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 19:30 EST by Joshua Schnee
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 18:06:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A patch to add the tux syscall (815 bytes, patch)
2004-03-08 16:17 EST, Bernd Schmidt
no flags Details | Diff

  None (edit)
Description Joshua Schnee 2003-12-11 19:30:27 EST
Description of problem:
System:
  System Vendor: Angstrom Microsystems 
   System Model: Titan 64 Classic 4 
      Processor: AMD Opteron 846, 2.0 GHz 
              #: 4 Processors
         Memory: 32 GB pc2100 DDR 
 Disk Subsystem: 3 Ultra320 SCSI 
     Disk Ctrls: Onboard LSI SCSI 
          Other: 4 Pro1000 MT dual port NICs
Uname -a:
Linux linux-udp01181162uds.amd.com 2.4.21-4.ELsmp #1 SMP Fri Oct 3 
17:32:58 EDT 2003 x86_64 x86_64 x86_64 GNU/Linux

Details:
While booted to the default kernel, and after setting 
up /etc/sysconfig/tux and tux.mime.types, I get the following error 
when trying to start tux.

/etc/rc.d/init.d/tux: Starting tux: TUX not implemented in this kernel
[FAILED]

Version-Release number of selected component (if applicable):
tux-3.2.14-1

How reproducible:
Every Time

Steps to Reproduce:
1.Install RHEL -3 AS
2.Setup /etc/sysconfig/tux & tux.mime.types
3.Start TUX
  
Actual results:
While booted to the default kernel, and after setting 
up /etc/sysconfig/tux and tux.mime.types, I get the following error 
when trying to start tux.

/etc/rc.d/init.d/tux: Starting tux: TUX not implemented in this kernel
[FAILED]


Expected results:
Starting tux:         [Done]

Additional info:

In the file "/usr/src/linux-2.4/include/asm-x86_64/unistd.h", add the 
following change:

427c427
< __SYSCALL(__NR_tuxcall, sys_ni_syscall)
---
> __SYSCALL(__NR_tuxcall, __sys_tux)

This will enable the system call for /usr/sbin/tux to actually work 
after you recompile the kernel. This is for RHEL AS3 (AMD64).
Comment 1 Hwaseop, keum 2004-02-02 04:10:03 EST
i have problem too.

{{{ H/W specs
OS: RHEL 3AS for amd 
kernel: both 2.4.21-9ELsmp, 2.4.21-4ELsmp
processor :Opteron 242, 1.6Ghz
.....
}}}

my error messge is "TUX not implemented in this kernel" too.

so i try strace

{{{ trace output 
shell>> strace tux 
...
tuxcall(0x17, 0, 0x505160)              = -1 ENOSYS (Function not
implemented)
write(2, "TUX not implemented in this kern"..., 35TUX not implemented
in this kernel
) = 35
exit_group(1)
}}}

after read bugzilla #111963

patch file "linux-2.4/include/asm-x86_64/unistd.h"
in build time i met error message follow:

{{{screen: kernel build error 
...
arch/x86_64/kernel/kernel.o(.data.cacheline_aligned+0x3dc0): undefined
reference to `__sys_tux'
make[1]: *** [kallsyms] Error 1
}}}

there is no patch line for x86_64 in "linux-2.4.21-tux.patch"
of kernel-2.4.21-9.EL.src.rpm 
Comment 3 Bernd Schmidt 2004-03-08 16:17:09 EST
Created attachment 98384 [details]
A patch to add the tux syscall

Other architectures seem to change the syscall depending on whether tux is
built in or built as a module - this patch seems to match what's done
elsewhere.  Verified to build on an x86-64 system.
Comment 4 Tim Burke 2004-05-20 21:04:47 EDT
Setting state to NEEDINFO. Because it is believed to be fixed in RHEL3
U2.  Please verify whether the bug persists in U2.
Comment 5 Bernd Schmidt 2004-06-23 17:45:51 EDT
According to the corresponding IT issue, this got fixed in U2.  Closing.

Note You need to log in before you can comment on or make changes to this bug.