Bug 1119670 - Supported maven version
Summary: Supported maven version
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Documentation
Version: 6.0.0 GA
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: CR3
: 6.0.0
Assignee: nshendye
QA Contact: Anton Giertli
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 09:17 UTC by Anton Giertli
Modified: 2014-09-28 23:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1121600 (view as bug list)
Environment:
Last Closed: 2014-09-28 23:31:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Anton Giertli 2014-07-15 09:17:45 UTC
Description of problem:
Productization team confirmed that for FSW 6.0 maven 3.0.x was used for building. Therefore we should promote this version as supported/recommended and explicitly mention it in the documentation.

There **may** be issues when different version of maven is used.

Comment 1 belong 2014-07-29 04:57:22 UTC
Nilam,

1. In our quickstart topics we currently say that Maven 3 is a prerequisite. Please update this to Maven 3.0.x in each of these topics.
2. Also please update the Install Maven topic to specify Maven 3.0.x in Step 1.

Regards,
Ben

Comment 2 nshendye 2014-08-01 07:06:48 UTC
Updated Maven version in the Quickstarts topics. Replaced all Maven 3 occurrences with 'Maven 3.0.x'. 

Docbuilder links:

http://docbuilder.usersys.redhat.com/13666/
http://docbuilder.usersys.redhat.com/16868/

- Nilam

Comment 3 belong 2014-09-17 06:42:41 UTC
Anton,

Please verify in:

http://docbuilder.usersys.redhat.com/22583/

Regards,
Ben

Comment 4 Anton Giertli 2014-09-19 07:42:54 UTC
Hi Ben,

thanks for this, looks good! I would maybe add it to the section about maven too, because SwitchYard application in general, should be build with maven 3.0.x when using FSW 6.0 dependencies.

i.e.
6.1. About Maven

[note]
Red Hat JBoss Fuse Service Works has been built with maven 3.0.x Therefore this is the recommended maven version which should be used for building your own SwitchYard application.

What do you think?

Anton.

Comment 5 belong 2014-09-22 00:05:16 UTC
Thank you, Anton!

Good idea. Note added: http://docbuilder.usersys.redhat.com/22586/#About_the_Maven_Repository1

Please verify.

Cheers,
Ben

Comment 6 Anton Giertli 2014-09-22 06:34:02 UTC
Looking good - setting VERIFIED.

Comment 7 belong 2014-09-28 23:31:04 UTC
Changes published live as part of bulk patch - Bug 1139484


Note You need to log in before you can comment on or make changes to this bug.