Bug 11197 - wrong output if "/." is appended to a filename (not dir)
Summary: wrong output if "/." is appended to a filename (not dir)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-03 14:37 UTC by schludi
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-03 14:37:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description schludi 2000-05-03 14:37:32 UTC
I don't know if this is a bug or a (incompatible) new feature:

If I append "/." to a existing file (not directory), then "ls" lists
the file. Older versions (as in redhat-5.2) didn't list the file.

This seems to break the "gnuserv" package. I didn't verify exactly what
happens, but it seems that gnuserv tries to load "<arg>/." and if this
succeeds, "<arg>" is supposed to be a directory and is listed in emacs.
If "<arg>/." gives no output, then something like `dirname <arg>` is
listed, and if `basename <arg>` is in the above output, then this file is
fetched.

this happens on redhat-5.2:

> Connected to pool2.syscomp.de.
> 220 pool2.syscomp.de FTP server (Version wu-2.4.2-academ[BETA-18](1) Mon
> Aug 3 19:17:20 EDT 1998) ready.
> 331 Password required for schludi.
> 230 User schludi logged in.
> Remote system type is UNIX.
> Using binary mode to transfer files.
> ftp> ls /etc/passwd/.
> 200 PORT command successful.
> 150 Opening ASCII mode data connection for /bin/ls.
> 226 Transfer complete.
> ftp> quit

and this happens on redhat-6.2:

> Connected to lxtest.syscomp.de.
> 220 lxtest.syscomp.de FTP server (Version wu-2.6.0(1) Mon Feb 28 10:30:36
> EST 2000) ready.
> 331 Password required for schludi.
> 230 User schludi logged in.
> Remote system type is UNIX.
> Using binary mode to transfer files.
> ftp> ls /etc/passwd/.
> 200 PORT command successful.
> 150 Opening ASCII mode data connection for /bin/ls.
> -rw-r--r--    1 root     root          801 Apr 17 13:33 /etc/passwd
> 226 Transfer complete.
> ftp> quit

Comment 1 Henri Schlereth 2000-07-12 23:36:17 UTC
ftp> ls /etc/passwd/.
200 PORT command successful.
150 Opening ASCII mode data connection for directory listing.
total 0
226 Transfer complete.

Fixed in 2.6.1.1, ,available at rawhide

Comment 2 schludi 2000-07-13 08:45:56 UTC
will there also be a redhat-6.2 update?

I have problems with the rawhide package, 
since it seems to be packed with rpm-4.0.



Note You need to log in before you can comment on or make changes to this bug.