Bug 1119724 - Can't visit spring-eap6-quickstart app with EAP-6.3
Summary: Can't visit spring-eap6-quickstart app with EAP-6.3
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: Brenton Leanhardt
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 11:20 UTC by xjia
Modified: 2014-10-14 15:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 15:11:45 UTC


Attachments (Terms of Use)

Description xjia 2014-07-15 11:20:46 UTC
Description of problem:
Following instructions in https://github.com/openshift/spring-eap6-quickstart#quickstart to deploy spring application. The homepage can't be visited.
For Openshift Online, it works fine.
For puddle:2.1.z/2014-07-14.1/ , it also works fine.
For puddle:2.1.z/2014-07-11.4,  it's using EAP 6.3 beta (https://github.com/openshift/openshift-extras/pull/400).Can't work.

Version-Release number of selected component (if applicable):
2.1.z/2014-07-11.4


How reproducible:
always

Steps to Reproduce:
1. rhc app create spring jbosseap-6
2. cd spring
3. git remote add upstream -m master git://github.com/openshift/spring-eap6-quickstart.git
4. git pull -s recursive -X theirs upstream master
5. git rm src/main/webapp/index.html
6. git commit -m 'Removed default index.html'
7. git push
8. Visit this app. 

Actual results:
[root@broker ~]# curl -i spring-jia.ose21z.example.com
HTTP/1.1 404 Not Found
Date: Tue, 15 Jul 2014 10:30:34 GMT
Server: Apache-Coyote/1.1
Content-Length: 0
Connection: close
Content-Type: text/plain; charset=UTF-8

Expected results:
Succeed to visit this app.

Additional info:
Log from spring app.

=========================================================================
  JBoss Bootstrap Environment
  JBOSS_HOME: /var/lib/openshift/53c4ffbb16ae310dd5000d62/jbosseap
  JAVA: /etc/alternatives/java_sdk_1.7.0/bin/java
  JAVA_OPTS:  -server -XX:+UseCompressedOops -XX:+TieredCompilation -Xmx256m -XX:MaxPermSize=102m -XX:+AggressiveOpts -Dorg.apache.tomcat.util.LOW_MEMORY=true -DOPENSHIFT_APP_UUID=53c4ffbb16ae310dd5000d62 -Dorg.jboss.resolver.warning=true -Djava.net.preferIPv4Stack=true -Dfile.encoding=UTF-8 -Djboss.node.name=spring-jia.ose21z.example.com -Djgroups.bind_addr=127.11.229.129 -Dorg.apache.coyote.http11.Http11Protocol.COMPRESSION=on
=========================================================================
2014/07/15 03:19:22,366 INFO  [org.jboss.modules] (main) JBoss Modules version 1.3.3.Final-redhat-1
2014/07/15 03:19:22,975 INFO  [org.jboss.msc] (main) JBoss MSC version 1.1.5.Final-redhat-1
2014/07/15 03:19:23,105 INFO  [org.jboss.as] (MSC service thread 1-1) JBAS015899: JBoss EAP 6.3.0.Beta2 (AS 7.4.0.Final-redhat-15) starting
2014/07/15 03:19:25,973 WARN  [org.jboss.as.messaging] (Controller Boot Thread) JBAS011608: Element CLUSTERED is deprecated and will not be taken into account
2014/07/15 03:19:27,769 INFO  [org.jboss.as.controller.management-deprecated] (ServerService Thread Pool -- 1) JBAS014627: Attribute clustered is deprecated, and it might be removed in future version!
2014/07/15 03:19:27,789 WARN  [org.jboss.messaging] (ServerService Thread Pool -- 1) JBAS011618: There is no resource matching the expiry-address jms.queue.ExpiryQueue for the address-settings #, expired messages from destinations matching this address-setting will be lost!
2014/07/15 03:19:27,795 WARN  [org.jboss.messaging] (ServerService Thread Pool -- 1) JBAS011619: There is no resource matching the dead-letter-address jms.queue.DLQ for the address-settings #, undelivered messages from destinations matching this address-setting will be lost!
2014/07/15 03:19:27,876 WARN  [org.jboss.as.server] (Controller Boot Thread) JBAS015883: No security realm defined for native management service; all access will be unrestricted.
2014/07/15 03:19:27,886 INFO  [org.xnio] (MSC service thread 1-4) XNIO Version 3.0.10.GA-redhat-1
2014/07/15 03:19:27,905 INFO  [org.xnio.nio] (MSC service thread 1-4) XNIO NIO Implementation Version 3.0.10.GA-redhat-1
2014/07/15 03:19:27,974 INFO  [org.jboss.as.server] (Controller Boot Thread) JBAS015888: Creating http management service using socket-binding (management-http)
2014/07/15 03:19:27,974 WARN  [org.jboss.as.server] (Controller Boot Thread) JBAS015884: No security realm defined for http management service; all access will be unrestricted.
2014/07/15 03:19:28,050 INFO  [org.jboss.remoting] (MSC service thread 1-4) JBoss Remoting version (unknown)
2014/07/15 03:19:28,269 INFO  [org.jboss.as.remoting] (MSC service thread 1-4) JBAS017100: Listening on 127.11.229.129:9999

Comment 2 Brenton Leanhardt 2014-07-16 20:57:16 UTC
I can definitely reproduce this.  The strange part is that put the ROOT.war that was built and fails to deploy in OpenShift in an EAP 6.3 standalone zip distribution works (once you disable the welcome page).

Comment 3 Brenton Leanhardt 2014-07-17 19:14:46 UTC
I'm still trying to understand exactly what changed in EAP 6.3.  By connecting to the management console I was able to get better debugging information.  The exact error was:

{
    "outcome" => "failed",
    "failure-description" => {"JBAS014671: Failed services" => {"jboss.deployment.unit.\"ROOT.war\".DEPENDENCIES" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"ROOT.war\".DEPENDENCIES: JBAS018733: Failed to process phase DEPENDENCIES of deployment \"ROOT.war\"
    Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: org.jboss.as.server.deployment.DeploymentUnitProcessingException: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011236: No spring integration jar found
    Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011236: No spring integration jar found
    Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011236: No spring integration jar found"}},
    "rolled-back" => true
}

Googling pointed me to Bug #1115569 where Yariv Dary mentioned adding a parameter to the application's web xml worked in there case.  I have just submitted the following pull request to the quickstart:

https://github.com/openshift/spring-eap6-quickstart/pull/5

You can test the steps in the original bug description using this repo:

https://github.com/brenton/spring-eap6-quickstart.git

We'd want to make sure this is compatible with OpenShift Online as well as a current EAP 6.2 deployment on OpenShift Enterprise.  I'm going to ask around why this change is even necessary.

Comment 4 Luke Meyer 2014-10-09 14:55:00 UTC
Does this work with EAP 6.2 and 6.3 and the PR? If so, we should merge it.

Comment 5 xjia 2014-10-10 10:00:22 UTC
Puddle:
2.1.z/2014-10-09.3

Verify:
[root@broker spring]# curl -i spring-jia.ose21z-auto.com.cn
HTTP/1.1 200 OK
Date: Fri, 10 Oct 2014 09:56:33 GMT
Server: Apache-Coyote/1.1
X-Powered-By: JSP/2.2
Content-Type: text/html;charset=ISO-8859-1
Content-Language: en-US
Content-Length: 3428
Set-Cookie: JSESSIONID=FwkPLR9Zyw+EqJzKN43N0+HJ; Path=/
Connection: close

No error log in ./jbosseap/standalone/log/server.log

Comment 6 Luke Meyer 2014-10-14 15:11:45 UTC
Since the quickstart has been addressed with the merging of https://github.com/openshift/spring-eap6-quickstart/pull/5 going to close this.


Note You need to log in before you can comment on or make changes to this bug.