Bug 1119749 - Qpid XML Exchange cannot be used on EL6
Summary: Qpid XML Exchange cannot be used on EL6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Pulp
Classification: Retired
Component: async/tasks
Version: 2.4 Beta
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
: 2.5.0
Assignee: Brian Bouterse
QA Contact: pulp-qe-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 12:32 UTC by Brian Bouterse
Modified: 2014-09-03 01:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 20:24:48 UTC


Attachments (Terms of Use)

Description Brian Bouterse 2014-07-15 12:32:27 UTC
The XML exchange functionality of Qpid is provided by the package qpid-cpp-server-xml which is produced from SRPM qpid-cpp. Pulp includes and delivers all qpid-cpp SRPM bits for EL6 from koji so a recent version of Qpid is available on EL6. The qpid-cpp-server-xml package is missing a dependency called 'xqilla' that is not available in base EL6 or EPEL. When a user goes to install the RPM, they get the following error message.

error: Failed dependencies:
        libxqilla.so.5()(64bit) is needed by qpid-cpp-server-xml-0.26-8.el6.x86_64
        xqilla is needed by qpid-cpp-server-xml-0.26-8.el6.x86_64

One workaround is the user could build the xqilla library from source.

Comment 1 Michael Hrivnak 2014-07-16 16:22:41 UTC
Blocked by qpid upstream.

Comment 2 Brian Bouterse 2014-07-16 17:59:21 UTC
Created an upstream bug to track the resolution of this Qpid issue in JIRA.

https://issues.apache.org/jira/browse/QPID-5901

Comment 3 Brian Bouterse 2014-07-16 20:24:48 UTC
XQilla is available for RHEL6 via RHN, and users should go there to get the dependencies they need to install this package.


Note You need to log in before you can comment on or make changes to this bug.