Bug 1119887 - numactl --show prints incorrect preferred node for case MPOL_BIND
Summary: numactl --show prints incorrect preferred node for case MPOL_BIND
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: numactl
Version: 7.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Petr Holasek
QA Contact: Jakub Prokes
URL:
Whiteboard:
: 1119888 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 18:18 UTC by Bill Gray
Modified: 2019-02-19 23:39 UTC (History)
5 users (show)

Fixed In Version: numactl-2.0.9-3.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 07:04:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0322 normal SHIPPED_LIVE numactl bug fix update 2015-03-05 11:57:36 UTC

Description Bill Gray 2014-07-15 18:18:57 UTC
"numactl --show" does not print the correct preferred node:

# for i in 0 1 2 3 4 5 6 7 ; do numactl -N$i -m$i numactl -s; done | grep preferred
preferred node: 4
preferred node: 4
preferred node: 4
preferred node: 4
preferred node: 4
preferred node: 4
preferred node: 4
preferred node: 4

# for i in 0 1 2 3 4 5 6 7 ; do ./numactl -N$i -m$i ./numactl -s; done | grep preferred
preferred node: 0
preferred node: 1
preferred node: 2
preferred node: 3
preferred node: 4
preferred node: 5
preferred node: 6
preferred node: 7

I send a patch to the linux-numa list to fix this on 7/15/2014, which will hopefully be included in numactl 2.0.10 when it becomes available.





Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Bill Gray 2014-07-15 18:32:30 UTC
*** Bug 1119888 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2015-03-05 07:04:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0322.html


Note You need to log in before you can comment on or make changes to this bug.