Bug 1119888 - numactl --show prints incorrect preferred node for case MPOL_BIND
Summary: numactl --show prints incorrect preferred node for case MPOL_BIND
Keywords:
Status: CLOSED DUPLICATE of bug 1119887
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: numactl
Version: 7.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Petr Holasek
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 18:20 UTC by Bill Gray
Modified: 2019-02-19 23:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-15 18:32:30 UTC


Attachments (Terms of Use)

Description Bill Gray 2014-07-15 18:20:16 UTC
"numactl --show" does not print the correct preferred node:

# for i in 0 1 2 3 4 5 6 7 ; do numactl -N$i -m$i numactl -s; done | grep preferred
preferred node: 4
preferred node: 4
preferred node: 4
preferred node: 4
preferred node: 4
preferred node: 4
preferred node: 4
preferred node: 4

# for i in 0 1 2 3 4 5 6 7 ; do ./numactl -N$i -m$i ./numactl -s; done | grep preferred
preferred node: 0
preferred node: 1
preferred node: 2
preferred node: 3
preferred node: 4
preferred node: 5
preferred node: 6
preferred node: 7

I send a patch to the linux-numa list to fix this on 7/15/2014, which will hopefully be included in numactl 2.0.10 when it becomes available.





Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Bill Gray 2014-07-15 18:32:30 UTC

*** This bug has been marked as a duplicate of bug 1119887 ***


Note You need to log in before you can comment on or make changes to this bug.