Bug 111995 - tg3 driver overflows user stack on ethtool ioctl
tg3 driver overflows user stack on ethtool ioctl
Status: CLOSED DUPLICATE of bug 112722
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-12 11:34 EST by Bill Nottingham
Modified: 2014-03-16 22:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test program (854 bytes, text/plain)
2003-12-12 11:35 EST, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2003-12-12 11:34:48 EST
Description of problem:

When using ETHTOOL_GLINK, the calling program's stack is trashed after
the ioctl.

Version-Release number of selected component (if applicable):

2.4.9-e.30, presumably later too.

How reproducible:

Every time.

Steps to Reproduce:
1. run the attached
2. note the segfault on return from function because the app has an
invalid stack
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2003-12-12 11:35:18 EST
Created attachment 96495 [details]
test program
Comment 2 Bill Nottingham 2004-02-03 11:53:45 EST

*** This bug has been marked as a duplicate of 112722 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:00:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.