Bug 1119977 - checksum mismatches on cached packages aren't actually dealt with
Summary: checksum mismatches on cached packages aren't actually dealt with
Keywords:
Status: CLOSED DUPLICATE of bug 1130685
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 03:29 UTC by Ben Boeckel
Modified: 2015-01-15 15:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-15 15:56:01 UTC


Attachments (Terms of Use)

Description Ben Boeckel 2014-07-16 03:29:48 UTC
dnf seems to refuse to do anything about packages in the cache when they don't match the metadata. Maybe dnf could move the file out of the way and try again? The files are large enough that I am definitely not actually downloading the file again from another mirror. It also looks like the webkitgtk RPMs were built using drpm, but it shouldn't matter how it got there; dnf can't trust that the cache is actually correct at all (the mirrors are the canonical source after all). There's also a typo (successfull -> successful).

Example output:

...
[SKIPPED] pixman-devel-0.32.6-2.fc22.x86_64.rpm: Already downloaded
[SKIPPED] terminus-fonts-4.39-1.fc22.noarch.rpm: Already downloaded
[SKIPPED] terminus-fonts-console-4.39-1.fc22.noarch.rpm: Already downloaded
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)
[MIRROR] webkitgtk3-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: fa7ae4409f4458b7b50d49bb8681cf9bc34aff3d336d4c54c9d1277159436703(sha256)
[MIRROR] webkitgtk3-devel-2.4.4-1.fc21.x86_64.rpm: Downloading successfull, but checksum doesn't match. Expected: 9f614eeae56fd53ee7480edd229d5c95b6545a4641f41b339a699c35f0926d28(sha256)

Version-Release number of selected component (if applicable):
dnf-0.5.3-1.fc21.noarch

Comment 1 Ben Boeckel 2014-07-16 03:47:49 UTC
So it seems that the drpm rebuilds failed (likely a separate bug) which is causing this. However, it'd be nice to try downloading what the mirror has rather than continuing to trust the cache.

Comment 2 Ales Kozumplik 2014-07-16 05:57:22 UTC
Thank you for the report, we'll take a look.

Comment 3 Honza Silhan 2014-11-24 19:16:50 UTC
Ben, can you try it with dnf-0.6.2, please? Seems like bug 1130685.

Comment 4 Ben Boeckel 2015-01-08 15:04:53 UTC
dnf-0.6.3-3.fc22 still exhibits the problem (with drpms in the mix at least).

Comment 5 Alexander Ploumistos 2015-01-14 10:02:49 UTC
I am also seeing this for the past few days after running
dnf clean all && dnf -y update

Comment 6 Honza Silhan 2015-01-15 15:56:01 UTC

*** This bug has been marked as a duplicate of bug 1130685 ***


Note You need to log in before you can comment on or make changes to this bug.