Bug 1120056 - Packstack fails to install neutron without ml2
Summary: Packstack fails to install neutron without ml2
Keywords:
Status: CLOSED DUPLICATE of bug 1119473
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Martin Magr
QA Contact: yfried
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 07:46 UTC by yfried
Modified: 2014-09-08 05:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 14:26:59 UTC


Attachments (Terms of Use)
logs for jenkins jobs. controller is under "node1" answer file is under "node1/root" (11.03 MB, application/x-bzip)
2014-07-16 07:46 UTC, yfried
no flags Details

Description yfried 2014-07-16 07:46:08 UTC
Created attachment 918344 [details]
logs for jenkins jobs. controller is under "node1" answer file is under "node1/root"

Description of problem:
trying to install neutron with vxlan (no ml2).
setup: controller + networker + 2computes

openstack-packstack-puppet-2014.1.1-0.34.dev1219.el7ost.noarch
openstack-packstack-2014.1.1-0.34.dev1219.el7ost.noarch


answer file attached in log tar

2014-07-16 09:56:46,019 - sshConnection - INFO - Adding Neutron API manifest entries                  [ DONE ]
2014-07-16 09:56:46,019 - sshConnection - INFO - Adding Neutron Keystone manifest entries             [ DONE ]
2014-07-16 09:56:46,019 - sshConnection - INFO - Adding Neutron L3 manifest entries                   [ DONE ]
2014-07-16 09:56:46,019 - sshConnection - INFO - Adding Neutron L2 Agent manifest entries          [ ERROR ]
2014-07-16 09:56:46,020 - sshConnection - INFO - 
2014-07-16 09:56:46,020 - sshConnection - INFO - ERROR : 'CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS'
2014-07-16 09:56:46,020 - sshConnection - INFO - Please check log file /var/tmp/packstack/20140716-095608-Edd6Dv/openstack-setup.log for more information



from /var/tmp/packstack/20140716-095608-Edd6Dv/openstack-setup.log:

2014-07-16 09:56:47::DEBUG::sequences::34::root:: Running step Adding Neutron L3 manifest entries.
2014-07-16 09:56:47::DEBUG::sequences::34::root:: Running step Adding Neutron L2 Agent manifest entries.
2014-07-16 09:56:47::DEBUG::sequences::40::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 38, in run
    self.function(config, messages)
  File "/usr/lib/python2.7/site-packages/packstack/plugins/neutron_350.py", line 914, in create_l2_agent_manifests
    manifestdata = getManifestTemplate(template_name)
  File "/usr/lib/python2.7/site-packages/packstack/modules/ospluginutils.py", line 76, in getManifestTemplate
    return fp.read() % controller.CONF
KeyError: 'CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS'

2014-07-16 09:56:47::ERROR::run_setup::920::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 915, in main
    _main(confFile)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 605, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 584, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 68, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 98, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 44, in run
    raise SequenceError(str(ex))
SequenceError: 'CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS'

Comment 2 yfried 2014-07-16 07:53:25 UTC
same result when trying to install gre without ml2

Comment 4 Martin Magr 2014-07-16 14:26:59 UTC

*** This bug has been marked as a duplicate of bug 1119473 ***


Note You need to log in before you can comment on or make changes to this bug.