Bug 1120275 - Nova: Boot an instance stuck "BUILD" status
Summary: Nova: Boot an instance stuck "BUILD" status
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: 5.0 (RHEL 6)
Assignee: Russell Bryant
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 15:29 UTC by Ido Ovadia
Modified: 2019-09-09 14:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 14:22:59 UTC


Attachments (Terms of Use)
answer file (15.97 KB, text/plain)
2014-07-16 15:29 UTC, Ido Ovadia
no flags Details
compute log (232.10 KB, text/x-log)
2014-07-16 15:30 UTC, Ido Ovadia
no flags Details
rabbit log (63.23 KB, text/x-log)
2014-07-17 11:06 UTC, Ido Ovadia
no flags Details

Description Ido Ovadia 2014-07-16 15:29:32 UTC
Created attachment 918452 [details]
answer file

Description of problem:
=======================
Boot an instance stuck "BUILD" status

Version-Release number of selected component (if applicable):
=============================================================

Puddle: 5.0-RHEL-6/2014-07-14.2

openstack-nova-common-2014.1.1-1.el6ost.noarch
openstack-nova-conductor-2014.1.1-1.el6ost.noarch
openstack-nova-cert-2014.1.1-1.el6ost.noarch
python-novaclient-2.17.0-2.el6ost.noarch
python-nova-2014.1.1-1.el6ost.noarch
openstack-nova-api-2014.1.1-1.el6ost.noarch
openstack-nova-console-2014.1.1-1.el6ost.noarch
openstack-nova-scheduler-2014.1.1-1.el6ost.noarch
openstack-nova-novncproxy-2014.1.1-1.el6ost.noarch

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Insall openstack-packstack (an answer file is enclosed)
2. Crete an image
3. Launch/Boot an instace from horizon or cli: 
nova boot --flavor 1 --key-name my_key_14_7 --image cirros Instance_cirros --nic net-id=d972291c-d934-4102-8932-33d37e93179b
   
Actual results:
================
Boot an instance stuck "BUILD" status

Expected results:
=================
Successfully build

Additional info:
================
answer file and nova/compute.log are enclosed

Comment 1 Ido Ovadia 2014-07-16 15:30:09 UTC
Created attachment 918453 [details]
compute log

Comment 2 Ido Ovadia 2014-07-16 15:37:34 UTC
Setup:
=====
Controller
Networker
2*Compute node

Comment 3 Russell Bryant 2014-07-16 15:50:36 UTC
Based on the compute log, it looks like you have connectivity problems with rabbitmq.  Is rabbitmq running properly?

Comment 4 Ido Ovadia 2014-07-17 11:06:44 UTC
Created attachment 918675 [details]
rabbit log

Comment 5 Russell Bryant 2014-07-17 14:22:59 UTC
It looks like rabbitmq got shut down.  You can see in the rabbit log it forcing all connections to closed:

=ERROR REPORT==== 15-Jul-2014::15:26:37 ===
AMQP connection <0.3389.0> (running), channel 0 - error:
{amqp_error,connection_forced,
            "broker forced connection closure with reason 'shutdown'",none}


And then after all of that settles, Nova just sits in a loop attempting to reconnect to rabbitmq.

Given that, I don't think this is a bug at all (and not a blocker).


Note You need to log in before you can comment on or make changes to this bug.