Bug 1120329 - /usr/bin/qemu-system-x86_64: error while loading shared libraries: librados.so.2
Summary: /usr/bin/qemu-system-x86_64: error while loading shared libraries: librados.so.2
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 18:35 UTC by Lokesh Mandvekar
Modified: 2014-08-22 17:12 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 19:16:11 UTC


Attachments (Terms of Use)

Description Lokesh Mandvekar 2014-07-16 18:35:39 UTC
Description of problem:

Not sure if qemu or libvirt bug.

Trying to start an ubuntu trusty guest gives me this:

$ virsh start trusty
error: Failed to start domain trusty
error: internal error: process exited while connecting to monitor: /usr/bin/qemu-system-x86_64: error while loading shared libraries: librados.so.2: cannot enable executable stack as shared object requires: Permission denied


NVR: qemu-system-x86-2.1.0-0.3.rc1.fc22.x86_64

Comment 1 Richard W.M. Jones 2014-07-16 19:03:12 UTC
(In reply to Lokesh Mandvekar from comment #0)
> /usr/bin/qemu-system-x86_64: error while loading shared libraries:
> librados.so.2: cannot enable executable stack as shared object requires:
> Permission denied

While that would indicate that librados.so.2 needs an executable
stack, I have just checked the latest Rawhide library and it's OK:

$ rpm2cpio ceph-libs-0.81.0-5.fc22.x86_64.rpm | cpio -id
$ readelf -l ./usr/lib64/librados.so.2.0.0 

...
  GNU_STACK      0x0000000000000000 0x0000000000000000 0x0000000000000000
                 0x0000000000000000 0x0000000000000000  RW     10
...

Which version of ceph-libs is installed?

Comment 2 Lokesh Mandvekar 2014-07-16 19:16:11 UTC
So looks like I had libcephfs1 and librados2 installed and not ceph-libs (probably something went wrong during my system upgrade(?)) ... I removed the former 2 and installed the latter, and everything seems to work now.

Thanks!

Comment 3 Richard W.M. Jones 2014-08-22 17:12:59 UTC
Likely to be a dupe of
https://bugzilla.redhat.com/show_bug.cgi?id=1118504


Note You need to log in before you can comment on or make changes to this bug.