Bug 112036 - Evolution handles threaded message list badly
Evolution handles threaded message list badly
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-13 05:20 EST by Andy Wallace
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 16:19:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Wallace 2003-12-13 05:20:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When View->Threaded Message List is turned on, the actual results are
erratic, with several threads displayed for the one thread, answers
inserted above questions etc.

In large-volume mailing lists (e.g. Fedora-list) this makes it very
difficult to follow anything.

Version-Release number of selected component (if applicable):
evolution-1.4.5-7

How reproducible:
Always

Steps to Reproduce:
1. Select View->Threaded Message List
2. Open a folder with a large number of threaded messages
3.
    

Actual Results:  Messages are threaded in the normal way, but it does
a very bad job of it - several threads started for the same thread,
answers above questions, etc.

Expected Results:  Threading is handled successfully

Additional info:
Comment 1 Bart Martens 2004-01-29 12:17:47 EST
Already registered at ximian bugzilla.

http://bugzilla.ximian.com/show_bug.cgi?id=41121
Comment 2 Andy Wallace 2004-01-29 13:39:04 EST
I've since discovered that this is caused by Outlook/Outlook Express
not honouring the In-Reply-To header, which is all Evolution uses to
figure out the threads. So if Outlook users take part in the thread,
Evolution threading doesn't work very well.

However, I've been told by a mutt user that it handles these threads
better by examining other headers as well to decide on the thread
sequence, so there is a possibility of improvement.
Comment 3 Jeremy Katz 2004-01-29 16:19:57 EST
Unfortunately, non-strict threading has a lot of other problems (I
used to use mutt and submit patches to it too :-)  evolution 1.0 or
thereabouts used non-strict threading but with either 1.2 or 1.4, they
switched to the more strict form because it keeps things far saner
overall.

Note You need to log in before you can comment on or make changes to this bug.