Bug 1120448 - 2.1.0-1.el6ost misses Requires: python-six
Summary: 2.1.0-1.el6ost misses Requires: python-six
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-swiftclient
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: 5.0 (RHEL 6)
Assignee: Lon Hohberger
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 00:48 UTC by Pete Zaitcev
Modified: 2016-04-26 21:40 UTC (History)
5 users (show)

Fixed In Version: python-swiftclient-2.1.0-2.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 19:07:48 UTC
zaitcev: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0951 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement - Object Storage 2014-07-28 23:07:20 UTC

Description Pete Zaitcev 2014-07-17 00:48:24 UTC
Description of problem:

[root@kvm-ni zaitcev]# rpm -U tmp/python-swiftclient-2.1.0-1.el6ost.noarch.rpm 
[root@kvm-ni zaitcev]# swift list
Traceback (most recent call last):
  File "/usr/bin/swift", line 20, in <module>
    from swiftclient.shell import main
  File "/usr/lib/python2.6/site-packages/swiftclient/shell.py", line 42, in <module>
    from swiftclient.multithreading import MultiThreadingManager
  File "/usr/lib/python2.6/site-packages/swiftclient/multithreading.py", line 22, in <module>
    from six.moves.queue import Queue
ImportError: No module named queue
[root@kvm-ni zaitcev]# 

Version-Release number of selected component (if applicable):

python-swiftclient-2.1.0-1.el6ost

How reproducible:

Packaging

Steps to Reproduce:
0. Make sure python-swiftclient-1.7 is installed
1. Make sure python-six is not installed (rpm -e python-six)
2. rpm -U python-swiftclient-2.1.0-1.el6ost.noarch.rpm
3. swift

Actual results:

Traceback

Expected results:

No traceback

Additional info:

Comment 3 Pete Zaitcev 2014-07-17 17:13:00 UTC
(changing flags to reflect RHEL 6 based release for this bug - will clone
if RHEL 7 trips too).

Comment 11 errata-xmlrpc 2014-07-28 19:07:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0951.html


Note You need to log in before you can comment on or make changes to this bug.