Bug 1120467 - [origin_cartridge_229][fork][Unable to threaddump ruby-2.0 app after access the app url
Summary: [origin_cartridge_229][fork][Unable to threaddump ruby-2.0 app after access t...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Hadvig
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 03:02 UTC by Yan Du
Modified: 2015-05-15 00:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-10 00:49:02 UTC


Attachments (Terms of Use)

Description Yan Du 2014-07-17 03:02:16 UTC
Description of problem:
root@openshift-ubuntu:~/test# rhc threaddump r20s
 Unable to detect application PID. Check the application's availability by accessing http://r20s-1.dev.rhcloud.com



Version-Release number of selected component (if applicable):
fork_ami_origin_cartridge_236_1223



How reproducible:
always


Steps to Reproduce:

1. Create a ruby-2.0 app
2. Visit the app in web
3. rhc threaddump r20



Actual results:
Same as description



Expected results:
could threaddump normally



Additional info:
works normally with ruby-1.9 app

root@openshift-ubuntu:~/test# rhc threaddump r19
Success
The thread dump file will be available via: rhc tail r19 -g 53c76da21e68eecd88000052 -f
/var/lib/openshift/53c76da21e68eecd88000052/app-root/logs//ruby* -o '-n 250'

Comment 1 Jakub Hadvig 2014-07-17 13:01:18 UTC
The application has to be visited before the using the threaddump,
in order to spawn the threaddump process.

Marking as Not a Bug.

Comment 2 Yan Du 2014-07-18 02:09:28 UTC
I have visited the app before running rhc threaddump. you can refer to the above detail steps or the bug title.

Test on devenv_4977,issue still can be reproduced. reopen the bug.

1. Visit the app and run theaddump
# rhc threaddump r20
 Unable to detect application PID. Check the application's availability by accessing http://r20-1.dev.rhcloud.com

2. click the url in step1 to access again

3. still got the message when running threaddump
# rhc threaddump r20
 Unable to detect application PID. Check the application's availability by accessing http://r20-1.dev.rhcloud.com

Comment 3 Michal Fojtik 2014-07-18 11:52:32 UTC
https://github.com/openshift/origin-server/pull/5619

Comment 4 openshift-github-bot 2014-07-18 12:40:34 UTC
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/370f6c244933c02a46ab54b831a096ef668daed1
Bug 1120467: Fixing wrong grep format for threaddump in ruby-2.0

Comment 5 Yan Du 2014-07-21 02:43:44 UTC
Test on devenv_4988

root@openshift-ubuntu:~/test# rhc threaddump r20
Success

The thread dump file will be available via: rhc tail r20 -g 53ccb2d181bc302bdf000732 -f /var/lib/openshift/53ccb2d181bc302bdf000732/app-root/logs//ruby* -o
'-n 250'

Move bug to verified. Thanks.


Note You need to log in before you can comment on or make changes to this bug.