Bug 112048 - Infinite recursion in readline
Infinite recursion in readline
Status: CLOSED DUPLICATE of bug 92372
Product: Red Hat Linux
Classification: Retired
Component: readline (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-13 14:20 EST by Bill Helfinstine
Modified: 2007-04-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Helfinstine 2003-12-13 14:20:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
When using the command-line ftp client, if you press Shift-Return, the
program will segfault.  Running gdb shows an infinite recursion within
readline.

It's very easy for my fingers to hit shift accidently when I press
return, I have found.






Version-Release number of selected component (if applicable):
readline-4.3-5

How reproducible:
Always

Steps to Reproduce:
1. ftp <return>
2. <shift-return>
3. watch it segfault
    

Actual Results:  flitterfly:bhelf% ftp
ftp> Segmentation fault (core dumped)
flitterfly:bhelf%


Expected Results:  flitterfly:bhelf% ftp
ftp>
ftp>


Additional info:

flitterfly:bhelf% gdb /usr/bin/ftp core.29484
GNU gdb Red Hat Linux (5.3post-0.20021129.18rh)
Copyright 2003 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and
you are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
details.
This GDB was configured as "i386-redhat-linux-gnu"...
(no debugging symbols found)...
Core was generated by `ftp ftp3.external.lmco.com'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/lib/libreadline.so.4...
(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libreadline.so.4
Reading symbols from /usr/lib/libncurses.so.5...(no debugging symbols
found)...
done.
Loaded symbols for /usr/lib/libncurses.so.5
Reading symbols from /lib/tls/libc.so.6...(no debugging symbols
found)...done.
Loaded symbols for /lib/tls/libc.so.6
Reading symbols from /lib/ld-linux.so.2...(no debugging symbols
found)...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /lib/libnss_files.so.2...(no debugging symbols
found)...
done.
Loaded symbols for /lib/libnss_files.so.2
Reading symbols from /lib/libnss_dns.so.2...(no debugging symbols
found)...
done.
Loaded symbols for /lib/libnss_dns.so.2
Reading symbols from /lib/libresolv.so.2...(no debugging symbols
found)...done.
Loaded symbols for /lib/libresolv.so.2
#0  0x400409b2 in _rl_dispatch_subseq () from /usr/lib/libreadline.so.4

(gdb) bt 10
#0  0x400409b2 in _rl_dispatch_subseq () from /usr/lib/libreadline.so.4
#1  0x4004077e in _rl_dispatch () from /usr/lib/libreadline.so.4
#2  0x40040803 in _rl_dispatch_subseq () from /usr/lib/libreadline.so.4
#3  0x4004077e in _rl_dispatch () from /usr/lib/libreadline.so.4
#4  0x40040803 in _rl_dispatch_subseq () from /usr/lib/libreadline.so.4
#5  0x4004077e in _rl_dispatch () from /usr/lib/libreadline.so.4
#6  0x40040803 in _rl_dispatch_subseq () from /usr/lib/libreadline.so.4
#7  0x4004077e in _rl_dispatch () from /usr/lib/libreadline.so.4
#8  0x40040803 in _rl_dispatch_subseq () from /usr/lib/libreadline.so.4
#9  0x4004077e in _rl_dispatch () from /usr/lib/libreadline.so.4
(More stack frames follow...)
(gdb)
Comment 1 Tim Waugh 2003-12-13 18:22:06 EST

*** This bug has been marked as a duplicate of 92372 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.