Bug 1120485 - [RFE][cinder]: Windows SMB Volume Driver
Summary: [RFE][cinder]: Windows SMB Volume Driver
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ga
: 6.0 (Juno)
Assignee: Eric Harney
QA Contact: nlevinki
URL: https://blueprints.launchpad.net/cind...
Whiteboard: upstream_milestone_juno-rc1 upstream_...
: 1098689 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 04:07 UTC by RHOS Integration
Modified: 2016-04-26 17:13 UTC (History)
5 users (show)

Fixed In Version: openstack-cinder-2014.2.1-1.el7ost
Doc Type: Enhancement
Doc Text:
A new volume driver has been added that supports SMB shares from Windows. The driver supports Windows Server 2012 (R2 included). Volumes are exported through SMB shares as disk images (similar flow to the NFS driver).
Clone Of:
Environment:
Last Closed: 2015-02-09 20:05:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 106046 None None None Never

Description RHOS Integration 2014-07-17 04:07:35 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/cinder/+spec/windows-smbfs-volume-driver.

Description:

The purpose of this blueprint is to add an SMB Cinder volume driver. It will include the minimum set of features required by the Juno release.

This driver will support Windows Server 2012 (R2 included) and it will be based on the volume driver that will be available for Linux distributions, which is drafted here: https://blueprints.launchpad.net/cinder/+spec/smbfs-volume-driver

Volumes will be exported through SMB shares as disk images, thus having a similar flow with the NFS driver.

Specification URL (additional information):

http://git.openstack.org/cgit/openstack/cinder-specs/tree/specs/juno/hyper-v-smbfs-volume-driver.rst

Comment 1 Sean Cohen 2014-07-23 12:57:49 UTC
*** Bug 1098689 has been marked as a duplicate of this bug. ***

Comment 4 Scott Lewis 2015-02-09 20:05:04 UTC
This bug has been closed as a part of the RHEL-OSP 6 general availability release. For details, see https://rhn.redhat.com/errata/rhel7-rhos-6-errata.html


Note You need to log in before you can comment on or make changes to this bug.