Bug 112053 - parted fails to recognize present partition information
parted fails to recognize present partition information
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-13 15:01 EST by Knut Zakariassen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 15:32:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut Zakariassen 2003-12-13 15:01:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030630

Description of problem:
Booting from Fedora Core 1 disk 1, existing partition information is
not  recognized during the install, when the disk is connected as
master/single on the 1st interface of the onboard promise ata-100
controller.

I get a message that states that no partiton information was found,
and  that the disk needs to be initialized. Furthermore, if i do this,
the disk seems to 'loose' some 30gb worth of space (After the init,
disk is reported to be approx 16000 cyls / 130gb instead of the 19000+
cylinders /160 gb that is the capacity of the drive.

If the drive, however, is connected as master to the second interface,
the full capacity is recognized. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Partition empty harddisk using linux fdisk
2. Boot from Fedora Core 1 Disk 1
3. Choose manual partitioning


Actual Results: 
The existing partition information is not recognized, and you are
given the choice to reinitialize the disk and start afresh. If you do
this, the disks capacity will be reduced with approx 30 gb (At least
thats what happens to me.)
If you choose not to reinitialize, the machine will reboot, due to not
finding any usable harddisk space.
    

Expected Results:  Present partitions should be recognized, and I
should get the choice on mountpoints for the different partitions.

Additional info:
Comment 1 Matt Wilson 2003-12-15 14:28:21 EST
I think that there might be a mismatch between the geometry used on
the disk, on the controller, and what's communicated to the kernel. 
Can you please provide all of the supported geometries for your drive,
what the BIOS reports, and what the kernel prints out in the bootup
messages?
Comment 2 Knut Zakariassen 2004-03-04 11:48:50 EST
The disk is a 160GB Seagate Barracuda 7200.7 Plus - ST3160023A

According to the user manual, the default logical geometry of the disk
is: 16 heads, 63 sectors/track, 16383 cylinders.

-------------
Mandrake 9.2:
-------------
/proc/ide/hde/geometry:
physical	19457/255/63
logical		19457/255/63
/proc/ide/hde/capacity:
312581808

fdisk -l /dev/hde:

Disk /dev/hde: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
...

--------------
Fedora Core 1:
--------------
/proc/ide/hde/geometry:
physical	19457/255/63
logical		19457/255/63
/proc/ide/hde/capacity:
268435456

fdisk -l /dev/hde:

Disk /dev/hde: 137.4 GB, 137438953472 bytes
255 heads, 63 sectors/track, 16709 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
...

dmesg | grep hde:
hde: ST3160023A, ATA DISK drive
hde: attached ide-disk driver.
hde: host protected area => 1
hde: LBA48 large I/O not supported, capacity limited to 137 Gb.
hde: 268435436 sectors (137439 MB) w/8192KiB Cache, CHS=16709/255/63,
UDMA(100)

Apparently LBA48 fails to be activated, or may not exist in the kernel
at all.
Comment 3 Axel Thimm 2004-04-30 02:55:10 EDT
I see the same behaviour with a Maxtor 6Y160P0 (160GB, PATA, no
partition table):

kernel: hdc: Maxtor 6Y160P0, ATA DISK drive
kernel: hdc: attached ide-disk driver.
kernel: hdc: host protected area => 1
kernel: hdc: LBA48 large I/O not supported, capacity limited to 137Gb.
kernel: hdc: 268435456 sectors (137439 MB) w/7936KiB Cache,
CHS=19929/255/63

# hdparm -i /dev/hdc

/dev/hdc:

 Model=Maxtor 6Y160P0, FwRev=YAR41BW0, SerialNo=Y444NC6E
 Config={ Fixed }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=57
 BuffType=DualPortCache, BuffSize=7936kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=268435455
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
 AdvancedPM=yes: disabled (255) WriteCache=enabled
 Drive conforms to: (null): 

 * signifies the current active mode

# fdisk -l /dev/hdc

Disk /dev/hdc: 137.4 GB, 137438953472 bytes
255 heads, 63 sectors/track, 16709 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/hdc doesn't contain a valid partition table

Note You need to log in before you can comment on or make changes to this bug.