Bug 1120568 - After creating a OS with description, the 'Name' column displays description text
Summary: After creating a OS with description, the 'Name' column displays description ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 07:37 UTC by Sachin Ghai
Modified: 2014-07-17 13:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 13:54:59 UTC


Attachments (Terms of Use)
'Name' Column displays 'description' text (44.12 KB, image/png)
2014-07-17 07:37 UTC, Sachin Ghai
no flags Details

Description Sachin Ghai 2014-07-17 07:37:55 UTC
Created attachment 918625 [details]
'Name' Column displays 'description' text

Description of problem:
I created a new OS with name, minor_version, major_version and description and os_family. But when I saw the list, found that 'description' text is displayed under 'Name' column

Version-Release number of selected component (if applicable):
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.21-1.el6sat.noarch
* foreman-compute-1.6.0.21-1.el6sat.noarch
* foreman-gce-1.6.0.21-1.el6sat.noarch
* foreman-libvirt-1.6.0.21-1.el6sat.noarch
* foreman-ovirt-1.6.0.21-1.el6sat.noarch
* foreman-postgresql-1.6.0.21-1.el6sat.noarch
* foreman-proxy-1.6.0.9-1.el6sat.noarch
* foreman-selinux-1.6.0-5.el6sat.noarch
* foreman-vmware-1.6.0.21-1.el6sat.noarch
* katello-1.5.0-26.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.53-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* rubygem-hammer_cli-0.1.1-5.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.1-9.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-2.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.4-7.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. create OS with description
2.
3.

Actual results:
'Name' Column displays 'description' text

Expected results:
"Name" column should display the name of OS instead of description

Additional info:
Please see attached screenshot

Comment 2 Greg Sutcliffe 2014-07-17 13:54:59 UTC
This is by design, so I'm closing as NOTABUG

For background, the "name" field is what Facter returns, which is "Redhat". We have a request to make Operatingsystems display as "Red Hat" for branding, but we did not want to alter how we interpret Facter data, so the view was made to use the description field instead. The "Name" field is only used if the description is blank.


Note You need to log in before you can comment on or make changes to this bug.