Bug 1120622 - Block domain's directories are not created correctly on a newly added host
Summary: Block domain's directories are not created correctly on a newly added host
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Federico Simoncelli
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 09:45 UTC by Ori Gofen
Modified: 2016-02-10 19:44 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 15:12:34 UTC
oVirt Team: Storage


Attachments (Terms of Use)

Description Ori Gofen 2014-07-17 09:45:45 UTC
Description of problem:
When adding a new host to a dc which has a block domain,vdsm skips the creation of
/rhev/data-center/mnt/blockSD/<SD>/dom_md/* directories.

root@camel-vdsb> tree                                                                                                                                                      /rhev/data-center
.
├── 00000002-0002-0002-0002-000000000204
│   ├── 118a5452-8beb-49ed-a0ae-daae113e7d54 -> /rhev/data-center/mnt/10.35.160.108:_RHEV_ogofen_1/118a5452-8beb-49ed-a0ae-daae113e7d54
│   ├── c2d6cb5e-268a-4870-b428-f29f8fa48d89 -> /rhev/data-center/mnt/blockSD/c2d6cb5e-268a-4870-b428-f29f8fa48d89
│   ├── ecf81e7e-f8bb-42b5-ab7a-0285d9c5f523 -> /rhev/data-center/mnt/10.35.160.108:_RHEV_ogofen_3/ecf81e7e-f8bb-42b5-ab7a-0285d9c5f523
│   └── mastersd -> /rhev/data-center/mnt/10.35.160.108:_RHEV_ogofen_3/ecf81e7e-f8bb-42b5-ab7a-0285d9c5f523
└── mnt
    ├── 10.35.160.108:_RHEV_ogofen_1
    │   ├── 118a5452-8beb-49ed-a0ae-daae113e7d54
    │   │   ├── dom_md
    │   │   │   ├── ids
    │   │   │   ├── inbox
    │   │   │   ├── leases
    │   │   │   ├── metadata
    │   │   │   └── outbox
    │   │   ├── images
    │   │   └── master
    │   └── __DIRECT_IO_TEST__
    ├── 10.35.160.108:_RHEV_ogofen_3
    │   ├── __DIRECT_IO_TEST__
    │   └── ecf81e7e-f8bb-42b5-ab7a-0285d9c5f523
    │       ├── dom_md
    │       │   ├── ids
    │       │   ├── inbox
    │       │   ├── leases
    │       │   ├── metadata
    │       │   └── outbox
    │       ├── images
    │       └── master
    │           ├── tasks
    │           └── vms
    └── blockSD
        └── c2d6cb5e-268a-4870-b428-f29f8fa48d89
            ├── dom_md
            └── images

where blockSD should be

   └── blockSD
        └── c2d6cb5e-268a-4870-b428-f29f8fa48d89
            ├── dom_md
            │   ├── ids -> /dev/c2d6cb5e-268a-4870-b428-f29f8fa48d89/ids
            │   ├── inbox -> /dev/c2d6cb5e-268a-4870-b428-f29f8fa48d89/inbox
            │   ├── leases -> /dev/c2d6cb5e-268a-4870-b428-f29f8fa48d89/leases
            │   ├── master -> /dev/c2d6cb5e-268a-4870-b428-f29f8fa48d89/master
            │   ├── metadata -> /dev/c2d6cb5e-268a-4870-b428-f29f8fa48d89/metadata
            │   └── outbox -> /dev/c2d6cb5e-268a-4870-b428-f29f8fa48d89/outbox
            └── images

Version-Release number of selected component (if applicable):
beta.1

How reproducible:
100%

Steps to Reproduce:
1.create a dc with 2 or more domains(one should be iscsi)
2.add new host to dc

Actual results:
dom_md dirs are not created

Expected results:
dom_md should be created

Additional info:

Comment 1 Federico Simoncelli 2014-08-06 09:12:40 UTC
The directories and links are created in lazy mode for block domains (the first time they're required). Is there any real problem that you encountered?

Comment 2 Ori Gofen 2014-08-10 08:22:58 UTC
I believe that this problem leads to SMP switch issues when the master domain is Block,but for now I don't have the proper steps to reproduce.

Comment 3 Federico Simoncelli 2014-08-11 12:20:02 UTC
(In reply to Ori from comment #2)
> I believe that this problem leads to SMP switch issues when the master
> domain is Block,but for now I don't have the proper steps to reproduce.

This should be fairly easy to reproduce. Please attach the evidence of any real problem.

Comment 4 Ori Gofen 2014-08-11 15:12:34 UTC
closed NOTABUG, no evidence of problems was found due to the creation of Blockdirs in lazy mode.


Note You need to log in before you can comment on or make changes to this bug.