Bug 1120683 - rpm -V mariadb-galera-server produces conflicts and unsatisfied dependency, causing the TPS to fail
Summary: rpm -V mariadb-galera-server produces conflicts and unsatisfied dependency, c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: mariadb-galera
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 5.0 (RHEL 6)
Assignee: Ryan O'Hara
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 12:33 UTC by Ami Jeain
Modified: 2016-04-27 01:23 UTC (History)
5 users (show)

Fixed In Version: mariadb-galera-5.5.37-8.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 15:31:52 UTC


Attachments (Terms of Use)

Description Ami Jeain 2014-07-17 12:33:27 UTC
Description of problem:

rpm -V mariadb-galera-server produces conflicts and unsatisfied dependency, causing the TPS to fail on VerifyTest

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. install the latest Icehouse release
2. run # rpm -V mariadb-galera-server
3.

Actual results:

# rpm -V mariadb-galera-server
Unsatisfied dependencies for mariadb-galera-server-5.5.37-7.el6ost.x86_64:
	mysql-server conflicts with mariadb-galera-server-5.5.37-7.el6ost.x86_64
	mysql-server conflicts with mariadb-galera-server-5.5.37-7.el6ost.x86_64

#rpm -q --conflicts mariadb-galera-server
MySQL-server  
mysql-server

# rpm -q --provides mariadb-galera-server |grep mysql-server
mysql-server = 5.5.37-7.el6ost
mysql-server(x86-64) = 5.5.37-7.el6ost




Expected results:

no conflicts at all

Additional info:

Comment 1 Ryan O'Hara 2014-07-17 14:19:37 UTC
Why is mysql-server being installed? This is expected behavior. You cannot have multiple  database servers installed simultaneously. For RHOS, we want mariadb-galera-server always. If any other database server is installed, it must be removed/replaced with mariadb-galera-server.

Comment 2 Ami Jeain 2014-07-17 14:48:51 UTC
mysql is not being installed at all. It is a check by the TPS system (rpm -V), and this is where it fails

Comment 3 Ryan O'Hara 2014-07-17 14:51:11 UTC
(In reply to Ami Jeain from comment #2)
> mysql is not being installed at all. It is a check by the TPS system (rpm
> -V), and this is where it fails

Then this needs fixed in TPS. This is not a bug in mariadb-galera.

Comment 4 Radek Bíba 2014-07-18 05:26:30 UTC
(In reply to Ryan O'Hara from comment #3)
> (In reply to Ami Jeain from comment #2)
> > mysql is not being installed at all. It is a check by the TPS system (rpm
> > -V), and this is where it fails
> 
> Then this needs fixed in TPS. This is not a bug in mariadb-galera.

TPS merely runs rpm -V mariadb-galera-server and parrots the output. It reports a problem because the exit status of rpm -V is greater than zero. How could that be a bug in TPS?

This is either some kind of packaging weirdness that confuses RPM (Provides: and Conflicts: have matching *unversioned* contents, this looks weird to me), or a bug in RPM.

Comment 5 Lon Hohberger 2014-07-18 15:17:07 UTC
I wonder, does TPS have mysql-server/mariadb-server in the test environment prior to us running the test for mariadb-galera-server?

If so, removing it prior to a TPS run would probably fix the issue.

The conflict is intentional, I think: we don't want people to end up accidentally switching their database out simply by running 'yum update -y', which is what we'd get if we did provies/obsoletes combination.

Hmm.

Comment 6 Lon Hohberger 2014-07-18 15:21:13 UTC
Interesting, the Fedora / RHEL7 spec have Obsoletes for mysql-server, but not mariadb-server, so I would have expected something similar to happen on the RHEL7 erratum (but for mariadb-server, not mysql-server)

Comment 7 Lon Hohberger 2014-07-18 15:22:54 UTC
I would expect there's a way to not install mysql-server in the TPS environment, which would eliminate this problem.

Comment 8 Lon Hohberger 2014-07-18 15:31:53 UTC
Ah, as Ami pointed out, it's conflicting with itself.  Hrm.

Comment 10 Ryan O'Hara 2014-07-18 15:54:29 UTC
OK, for now I am just removing "Conflicts: mysql-server" for the mariadb-galera-server subpackage. It will still conflict with mysql-server, but it will be a file level conflict, not explicitly stated in the spec file. I tested this and it works on RHEL6.

Comment 11 Ami Jeain 2014-07-20 11:22:40 UTC
issue has been fixed

Comment 12 Scott Lewis 2014-07-29 15:31:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0928.html


Note You need to log in before you can comment on or make changes to this bug.