Bug 1120716 - Bootdisk should be configured for all Operating Systems By default
Summary: Bootdisk should be configured for all Operating Systems By default
Keywords:
Status: CLOSED DUPLICATE of bug 1107743
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 14:35 UTC by Justin Sherrill
Modified: 2017-02-23 21:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 14:57:03 UTC


Attachments (Terms of Use)

Description Justin Sherrill 2014-07-17 14:35:40 UTC
Description of problem:

Currently when installing sat6, you have to do two things to configure bootdisk:

Hosts > Provisioning Templates > Kickstart default iPXE > Association > tick the Operating systems
Hosts > Operating systems > for each OS > templates > select 'Kickstart default iPXE' for 'iPXE' drop down


This should be done by default for all Red Hat Operating systems.

Comment 2 Stephen Benjamin 2014-07-17 15:59:55 UTC
I agree - we should do it for all the templates, there's already an upstream issue to make this friendlier for everything:

  http://projects.theforeman.org/issues/6370

We already store metadata about most of the templates at the top:

<%#
name: xxxx
oses:
 - CentOS 5
 - CentOS 6
%>

We should use that to automatically make the right associations, it's probably not too difficult to do.

Comment 3 Brad Buckingham 2014-08-07 18:08:57 UTC
Assigning to Stephen since there is an upstream PR for issue 6370, mentioned in #2.

Comment 4 Stephen Benjamin 2014-10-14 14:57:03 UTC
iPXE assoication is done in BZ1107743

*** This bug has been marked as a duplicate of bug 1107743 ***


Note You need to log in before you can comment on or make changes to this bug.