Bug 112076 - anaconda does not support HD upgrade with ISOs on single member of RAID set
anaconda does not support HD upgrade with ISOs on single member of RAID set
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-13 21:00 EST by Alik Widge
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 11:48:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump file. (61.96 KB, text/plain)
2003-12-13 21:08 EST, Alik Widge
no flags Details
raidtab file from the system (1.15 KB, text/plain)
2003-12-13 22:01 EST, Alik Widge
no flags Details

  None (edit)
Description Alik Widge 2003-12-13 21:00:28 EST
Description of problem:

I am attempting to do an upgrade from RH 7.2 to Fedora Core 1 using
ISOs on a hard drive. Software RAID is in place on said hard drive to
mirror its contents to the machine's secondary drive. 

After finding images and choosing the bootloader, Anaconda crashes
with a nice little stack trace (attached).

Version-Release number of selected component (if applicable):

Not sure -- whatever's on the Fedora Core 1 install diskette.

How reproducible:

100% reproducible and robust to changes in install params (such as
choosing LILO instead of GRUB).


Steps to Reproduce:
1. Download ISOs to directory on /dev/md1 (also /dev/hda2)
2. Make boot diskette from bootdisk.img
3. Run installation off boot diskette as usual.
  
Actual results:

Unhandled exception thrown by Anaconda, system not upgraded.


Expected results:

System upgraded to Fedora Core 1.


Additional info:

Attached dump file.
Comment 1 Alik Widge 2003-12-13 21:08:04 EST
Created attachment 96513 [details]
Anaconda dump file.

I did review this trace briefly, and I think maybe the problem is one of
filesystems. The trace seems to think that the images are on an ext2 filesystem
on /dev/hda2, but that filesystem is actually ext3 last I checked.
Comment 2 Jeremy Katz 2003-12-13 21:33:12 EST
Is hda2 part of one of the raid arrays on the system?
Comment 3 Alik Widge 2003-12-13 21:58:07 EST
Yes, hda2 is part of the RAID. I'm attaching the raidtab to help.
Comment 5 Alik Widge 2003-12-13 22:00:23 EST
Comment on attachment 96520


>Last login: Sat Dec 13 21:51:26 2003 from pittmed.medschool.pitt.edu
>[alik@mdphd alik]$ cls
>cls
>bash: cls: command not found
>[alik@mdphd alik]$ clr
>clr
>bash: clr: command not found
>[alik@mdphd alik]$ clear
>clear
>[alik@mdphd alik]$ reset
>reset
>Erase is delete.
>Kill is control-U (^U).
>Interrupt is control-C (^C).
>[alik@mdphd alik]$ cat /etc/raidtab 
>cat /etc/raidtab 
>raiddev		    /dev/md0
>raid-level		    1
>nr-raid-disks		    2
>chunk-size		    64k
>persistent-superblock	    1
>#nr-spare-disks	    0
>    device	    /dev/hda1
>    raid-disk     0
>    device	    /dev/hdc1
>    raid-disk     1
>raiddev		    /dev/md1
>raid-level		    1
>nr-raid-disks		    2
>chunk-size		    64k
>persistent-superblock	    1
>#nr-spare-disks	    0
>    device	    /dev/hda2
>    raid-disk     0
>    device	    /dev/hdc2
>    raid-disk     1
>raiddev		    /dev/md2
>raid-level		    1
>nr-raid-disks		    2
>chunk-size		    64k
>persistent-superblock	    1
>#nr-spare-disks	    0
>    device	    /dev/hda5
>    raid-disk     0
>    device	    /dev/hdc5
>    raid-disk     1
>raiddev		    /dev/md3
>raid-level		    1
>nr-raid-disks		    2
>chunk-size		    64k
>persistent-superblock	    1
>#nr-spare-disks	    0
>    device	    /dev/hda6
>    raid-disk     0
>    device	    /dev/hdc6
>    raid-disk     1
>raiddev		    /dev/md4
>raid-level		    1
>nr-raid-disks		    2
>chunk-size		    64k
>persistent-superblock	    1
>#nr-spare-disks	    0
>    device	    /dev/hda7
>    raid-disk     0
>    device	    /dev/hdc7
>    raid-disk     1
>
>[alik@mdphd alik]$
Comment 6 Alik Widge 2003-12-13 22:01:06 EST
Created attachment 96521 [details]
raidtab file from the system
Comment 7 Jeremy Katz 2003-12-14 11:27:43 EST
We don't currently support using a single member of a RAID set as the
source for a hard drive install as we have to do weird mount/umount
magic for things at various points and once the RAID device has been
started, we can't do that.
Comment 8 Alik Widge 2003-12-14 11:30:52 EST
So, in other words, the only known solution for this problem is to 
try to find a system that's got both broadband and a CD burner and 
burn the ISOs to CDs.

If I do that (which I can, even though it's a hassle), is there 
anything else I should be aware of when trying to do an upgrade 
install on a RAID?
Comment 9 Jeremy Katz 2003-12-14 11:34:10 EST
That's the only caveat I can think of.
Comment 10 Jeremy Katz 2004-10-05 11:48:49 EDT
At this point, not really planning on implementing support for doing this.

Note You need to log in before you can comment on or make changes to this bug.