Bug 1120773 - [rpm] tomcat7 with tomcat-natives cookie problem
Summary: [rpm] tomcat7 with tomcat-natives cookie problem
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: tomcat-native, tomcat7
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: CR01
: 2.1.0
Assignee: Jean-frederic Clere
QA Contact: Michal Haško
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 15:55 UTC by Michal Haško
Modified: 2014-07-25 12:40 UTC (History)
3 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-25 12:40:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Michal Haško 2014-07-17 15:55:10 UTC
affects el5,6,7 with tomcat-native installed:

tomcat7-7.0.54-4_patch_01.ep6.el5
tomcat-native-1.1.30-1.redhat_1.ep6.el5

tomcat7-7.0.54-4_patch_01.ep6.el6
tomcat-native-1.1.30-1.redhat_1.ep6.el6

tomcat7-7.0.54-2_patch_01.ep6.el7
tomcat-native-1.1.30-1.redhat_1.ep6.el7

(issue not present when tomcat-native is not installed)

steps to reproduce:
1. install tomcat7 & tomcat-native
2. create user tomcat in tomcat-users.xml:
   <user username="tomcat" password="tomcat" roles="tomcat,admin-gui,manager-gui,manager-status,manager-jmx,manager-script"/>
3. naviage to localhost:8080/host-manager/html and sign in as user tomcat
4. Add virtual host. name: "test", appbase: "testwebapps"

a message about invalid cookie appears in catalina.out:
...
Jul 17, 2014 11:48:07 AM org.apache.tomcat.util.http.Cookies processCookieHeader
INFO: Cookies: Invalid cookie. Value not a token or quoted value
 Note: further occurrences of Cookie errors will be logged at DEBUG level.
Jul 17, 2014 11:48:12 AM org.apache.catalina.startup.HostConfig deployDescriptor

Comment 1 Weinan Li 2014-07-21 15:31:05 UTC
Jean-Frederic, could you please help to check this?

Comment 2 Jean-frederic Clere 2014-07-22 08:22:11 UTC
I am not able to reproduce it...

Comment 3 Jean-frederic Clere 2014-07-22 11:38:45 UTC
To debug please add the following in server.xml in the Engine for example:
+++
  name="Catalina">
      <Valve className="org.apache.catalina.valves.AccessLogValve" pattern="%h %l %u %t %r %>s %b %{Referer}i %{User-Agent}i START: %{Cookie}i END"/>
+++
The cookie header should should what is wrong.

Comment 4 Michal Haško 2014-07-25 12:40:19 UTC
I cannot reproduce it anymore on:

tomcat7-7.0.54-6_patch_02.ep6.el5
tomcat7-7.0.54-6_patch_02.ep6.el6
tomcat7-7.0.54-4_patch_02.ep6.el7
tomcat-native-1.1.30-1.redhat_1.ep6.el5
tomcat-native-1.1.30-1.redhat_1.ep6.el6
tomcat-native-1.1.30-1.redhat_1.ep6.el7


Note You need to log in before you can comment on or make changes to this bug.