Bug 1120799 - swift_ext4_device does not mount when changing from swift_loopback = true to false in swift/storage.pp
Summary: swift_ext4_device does not mount when changing from swift_loopback = true to ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: Installer
Assignee: Jason Guiditta
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 18:01 UTC by jliberma@redhat.com
Modified: 2014-09-23 15:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-23 15:12:06 UTC


Attachments (Terms of Use)

Description jliberma@redhat.com 2014-07-17 18:01:04 UTC
Description of problem: swift/storage.pp is backed by either a local loopback device (swift_loopback = true) or a file system device. (swift_loopback = false; swift_ext4_device=/dev/sdb1)

In foreman, if you specify swift_loopback = true and create a loopback devuice, and then change to false and add a file system device (as a customer might migrate from a POC loopback to a partition) a puppet apply completes successfully but does not mount the file system device. If you manually dismount the loopback device and re-run it mounts appropriately.

Version-Release number of selected component (if applicable):
openstack-puppet-modules-2014.1-19.1.el7ost.noarch

How reproducible:
Every time.

Steps to Reproduce:
1. Deploy a Swift storage node via Foreman with swift_loopack = true
2. Add a formatted disk device (in my lab I used iSCSI /dev/sdb1)
3. Change Swift storage node host group parameters: swift_loopback = false, swift_ext4_device = /dev/sdb1
4. Run puppet agent -tdv on the Swift storage node
5. Run mount to verify
6. Unmount the loopback device and re-run puppet agent -tdv
7. Run mount to verify

Actual results:
puppet apply completes without error but disk device is not used

Expected results:
puppet apply should fail with error or disk device should be used

Additional info:
A conditional umoun expression should be added to swift/storage.pp. I will tackle this when I can find time.

Comment 2 Ivan Chavero 2014-08-11 23:41:48 UTC
this seems more like a foreman bug than a openstack puppet modules bug changing the component.

Comment 4 Mike Burns 2014-09-23 15:12:06 UTC
Closed wontfix for now since we don't deploy swift.  Will re-evaluate this when swift is supported


Note You need to log in before you can comment on or make changes to this bug.