Bug 112083 - mkinitrd keys lvm1/2 off running system, not kernel version
mkinitrd keys lvm1/2 off running system, not kernel version
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: mkinitrd (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-14 05:22 EST by Alexandre Oliva
Modified: 2007-04-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-13 14:21:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2003-12-14 05:22:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031202

Description of problem:
If I've just installed kernel 2.6, but still haven't booted into it,
mkinitrd will set things up to use lvm version 1, not version 2, in
the 2.6 initrd.  This obviously won't work.

Testing the existing devices of the running system is of no use to
decide which lvm version is going to be available when the given
kernel boots.  It should probably look at the kernel version number
provided in the command line to decide whether to use lvm1 or lvm2.

Version-Release number of selected component (if applicable):
mkinitrd-3.5.15.1-2

How reproducible:
Always

Steps to Reproduce:
1.Boot into kernel 2.4, with root in a LV
2.Install kernel 2.6
3.Reboot into it


Actual Results:  It won't work, but not only because the LV devices
are not set up.  It will fail before it gets to that point, when it
attempts to run the lvm1 programs within kernel 2.6.

Expected Results:  Since it's kernel 2.6, it should arrange to use
lvm2, no matter what's being used in kernel 2.4.

Additional info:

It actually fails to initialize variables root_lvm and root_lvm2, but
even if I set root_lvm2=1 in mkinitrd's environment, it fails, because
then it tries *both* lvm1 and lvm2, and the former fails.
Comment 1 Jeremy Katz 2003-12-14 11:32:07 EST
Yes, I know -- this was listed in my caveats when I first sent mail
about it to one of the fedora lists.  Just wanted to get things
working enough for installs first, migration and upgrades second. 
Have a WIP on my laptop that I'm planning to test once I get back to
the office (probably Tuesday)
Comment 2 Jeremy Katz 2004-02-09 13:45:49 EST
It actually checks the kernel version now
Comment 3 Alexandre Oliva 2004-02-13 14:21:08 EST
Confirmed, thanks!  (I've only tested this by running mkinitrd for my
FC2test1 install tree within a chroot, from a FC1 boot session, but
that's enough of an indication to me that it works)

Note You need to log in before you can comment on or make changes to this bug.