Bug 1120830 - [EARLY ACCESS] confusing error message when attempting to snapshot thick logical volumes
Summary: [EARLY ACCESS] confusing error message when attempting to snapshot thick logi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: RHGS 3.0.0
Assignee: rjoseph
QA Contact: Sachin Pandit
URL:
Whiteboard: SNAPSHOT
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-17 19:45 UTC by James Rankin
Modified: 2016-09-17 12:59 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.6.0.27-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-22 19:44:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1278 normal SHIPPED_LIVE Red Hat Storage Server 3.0 bug fix and enhancement update 2014-09-22 23:26:55 UTC

Description James Rankin 2014-07-17 19:45:15 UTC
Description of problem in RHS 3.0 Early Access release:

Using RHS 3 Early access, if one attempt to take a volume snapshot of a volume *not* using dm-thinp, the error message is a fairly vague "check logs" message. The logs do not make the nature of the issue clear.

Many people may, skipping over the docs, configure RHS 3 using the previous methods without dm-thinp, and this will result in unneeded support tickets. I'd suggest having the CLI provide a very specific error message when a snap is attempted of a non dm-thinp LV.

Comment 2 SATHEESARAN 2014-07-18 07:02:48 UTC
marking the component as "gluster-snapshot"

Comment 3 Vivek Agarwal 2014-07-28 07:06:09 UTC
Agreed in a discussion between Rajesh and PM, providing the necessary flags

Comment 5 Avra Sengupta 2014-07-30 09:43:06 UTC
Fix at https://code.engineering.redhat.com/gerrit/29994

Comment 6 Sachin Pandit 2014-08-07 09:14:26 UTC
******************************************************
With previous build, snapshot creation on non-thin LV used to fail with the following error.

[root@snapshot-05 ~]# gluster snapshot create snap1 vol1
snapshot create: failed: Commit failed on localhost. Please check log file for details.
******************************************************

Tried the mentioned steps using build glusterfs-3.6.0.27-1. (latest build)

[root@snapshot-03 ~]# rpm -qa | grep gluster
glusterfs-fuse-3.6.0.27-1.el6rhs.x86_64
glusterfs-rdma-3.6.0.27-1.el6rhs.x86_64
glusterfs-libs-3.6.0.27-1.el6rhs.x86_64
glusterfs-api-3.6.0.27-1.el6rhs.x86_64
glusterfs-cli-3.6.0.27-1.el6rhs.x86_64
glusterfs-geo-replication-3.6.0.27-1.el6rhs.x86_64
glusterfs-debuginfo-3.6.0.27-1.el6rhs.x86_64
glusterfs-3.6.0.27-1.el6rhs.x86_64
glusterfs-server-3.6.0.27-1.el6rhs.x86_64


1) Created a volume using non thin-lv.

[root@snapshot-03 ~]# gluster volume create vol1 10.70.42.209:/non_lvm/b0 force
volume create: vol1: success: please start the volume to access data

[root@snapshot-03 ~]# gluster v i
 
Volume Name: vol1
Type: Distribute
Volume ID: 049a8db1-3876-414c-af3c-435eb43064d9
Status: Started
Snap Volume: no
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: 10.70.42.209:/non_lvm/b0
Options Reconfigured:
performance.readdir-ahead: on
auto-delete: disable
snap-max-soft-limit: 90
snap-max-hard-limit: 256

**non_lvm is the folder created on root partition, which is basically not
a thinly provisioned volume**


2) started the volume

[root@snapshot-03 ~]# gluster volume start vol1
volume start: vol1: success


3) Tried to take a snapshot

[root@snapshot-03 ~]# gluster snapshot create snap1 vol1
snapshot create: failed: Snapshot is supported only for thin provisioned LV. Ensure that all bricks of vol1 are thinly provisioned LV.
Snapshot command failed

**The error message displayed is proper, hence moving this bug to VERIFIED state**

Comment 8 errata-xmlrpc 2014-09-22 19:44:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1278.html


Note You need to log in before you can comment on or make changes to this bug.