Bug 112091 - jserver does not support TCP/IP connection against port 22273.
jserver does not support TCP/IP connection against port 22273.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: FreeWnn (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-14 08:49 EST by Kenichi Okuyama
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.10pl020
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 23:23:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenichi Okuyama 2003-12-14 08:49:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Emacs+Tamago requires to connect FreeWnn jserver over TCP/IP port 22273,
no matter connection between local or remote.
Original FreeWnn 1.1.1 a017 do support this connection as default, but
FreeWnn package of Fedora Core1 is arranged not to support TCP/IP:22273.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install FreeWnn, and let it activate with "setup" command.
2.$ netstat -a
3.check TCP/IP connection and make sure that port 22273, wnn4, nor
wnn6 is not in the list as CONNECT nor LISTEN
    

Expected Results:  TCP/IP port 22273 (or service wnn6) have one or
more "LISTEN" state.

Additional info:

FreeWnn newest packages are  FreeWnn-1.1.1-a018.tar.bz2  at
http://www.jazzdisco.org/bsdi/software/freewnn/

Since current version is FreeWnn-1.1.1-a017, update might be required
anyway.
Comment 1 Jens Petersen 2004-01-28 06:50:48 EST
Yep this was done for security reasons.  A coming version of
Emacs should have unix domain socket support, so at that
point it should be easy to make tamago use that (that's
the reason tamago isn't in the distro currently).  Until
then you'll have to disable or modify FreeWnn-1.1.1-unix.patch
in the source rpm and rebuild I'm afraid.

However it seems more recent version of FreeWnn have a
Unix Domain socket cli switch, so perhaps the patch is
no longer necessary.  I'll try to update to a020 soon
and hopefully that will help - thanks! :-)
Comment 2 Kenichi Okuyama 2004-01-29 15:20:05 EST
 Thank you.
 Beside Security, I believe there will be a chance of Wnn6 and FreeWnn
asking for same port number. Since FreeWnn have parameter switch to
change port number, I think we should have that to be part of script too.
 Did you not had this problem in past? I mean port number batting?
Comment 3 Jens Petersen 2004-03-22 22:31:16 EST
Updating to pl20 which has -u, -4 and -6 options,
so inet can be re-enabled.
Comment 4 Kunihiko IMAI 2004-05-01 01:16:31 EDT
I trapped the modification of disabling INET domain socket :)  And I
understood why it did.

But there are no documentation of this modification with the
distribution.  Only source code patch tells what is modified.

It is better to add some document about this modification, I think.
Comment 5 Kenichi Okuyama 2004-05-02 12:38:56 EDT
Jens, Where can I find your new pl20 version of FreeWnn?

I could only find FreeWnn-1.1.1-a017 version on 
http://download.fedora.redhat.com/
And this version does not seems to have -u, -4 nor -6 option on jserver...


IMAI, I found that FreeWnn does not have jserver man-page written in
language other than Japanese, at least, on FreeWnn-1.1.1-a017 version,
they don't. Hence, I think first thing we should do is look for pl20
version of package, and add man-page written in, at least, English.

Then, Jens can add patch to the man-page.
Comment 6 Jens Petersen 2004-08-05 22:24:34 EDT
Sorry for the long delay.

There were some build problems on AMD64 architecture
which delayed the update to pl20, but it has now been
in rawhide for over a month. :)

Anyway could you please try it and see if it makes things
better?  Thank you. :)
Comment 7 Jens Petersen 2004-09-28 23:23:41 EDT
jserver -4 seems to work ok now.  Closing.

Note You need to log in before you can comment on or make changes to this bug.