Bug 112099 - mkinitrd doesn't copy /etc/lvm/lvm.conf to initrd
mkinitrd doesn't copy /etc/lvm/lvm.conf to initrd
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: mkinitrd (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-14 12:43 EST by Alexandre Oliva
Modified: 2007-04-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-13 14:19:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that arranges for /etc/lvm/lvm.conf to be copied into initrd (338 bytes, patch)
2003-12-14 12:47 EST, Alexandre Oliva
no flags Details | Diff

  None (edit)
Description Alexandre Oliva 2003-12-14 12:43:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031202

Description of problem:
When using RAID physical volumes, one has to set up /etc/lvm/lvm.conf
such that vgscan skips the component partitions of the raid devices. 
If the root filesystem is a LV of such a VG, lvm.conf must be copied
to initrd.

Version-Release number of selected component (if applicable):
mkinitrd-3.5.15.1-2

How reproducible:
Always

Steps to Reproduce:
1.Set up the root filesystem in a volume group containing raid devices
2.Try to boot kernel 2.6 with lvm2

Actual Results:  vgscan in initrd fails because of ``duplicate�� entries.

Expected Results:  Ideally, they'd be skipped automatically by lvm2,
but it doesn't take care of it by itself, relying on lvm.conf instead.
 So we have to set up lvm.conf and copy it to the initrd filesystem.

Additional info:
Comment 1 Alexandre Oliva 2003-12-14 12:47:40 EST
Created attachment 96523 [details]
Patch that arranges for /etc/lvm/lvm.conf to be copied into initrd
Comment 2 Jeremy Katz 2004-02-09 13:50:30 EST
Committed to CVS, will be in 3.5.19
Comment 3 Alexandre Oliva 2004-02-13 14:19:28 EST
Confirmed fixed, thanks!

Note You need to log in before you can comment on or make changes to this bug.