Bug 1120997 - "oom_plugin.rb:25: warning: already initialized constant OP_TIMEOUT" in watchman.output
Summary: "oom_plugin.rb:25: warning: already initialized constant OP_TIMEOUT" in watch...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Brenton Leanhardt
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 06:11 UTC by Anping Li
Modified: 2015-10-12 14:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-12 14:26:48 UTC


Attachments (Terms of Use)

Description Anping Li 2014-07-18 06:11:30 UTC
Description of problem:
There are warning message "oom_plugin.rb:25: warning: already initialized constant OP_TIMEOUT" in watchman.output. it seems the OP_TIMEOUT was reinitialized. The error should be fixed.

Version-Release number of selected component (if applicable):
OSE2.1.z-2014-07-17.1

How reproducible:
100%

Steps to Reproduce:
1. service openshift-watchman restart
2. watch /var/log/watchman.output

Actual results:
There is warning message:
/etc/openshift/watchman/plugins.d/oom_plugin.rb:25: warning: already initialized constant OP_TIMEOUT
/etc/openshift/watchman/plugins.d/oom_plugin.rb:25: warning: already initialized constant OP_TIMEOUT
/etc/openshift/watchman/plugins.d/oom_plugin.rb:25: warning: already initialized constant OP_TIMEOUT


Expected results:

There isn't warning message.

Additional info:

Comment 1 Miciah Dashiel Butler Masters 2015-10-11 04:21:39 UTC
Looks like this defect was fixed along with another defect in commit <https://github.com/openshift/origin-server/commit/3f92ecc1b1bc6b65b3db738db1b317a6aca7bfea>, which shipped in openshift-origin-node-util-1.32.4.1-1.el6op with RHBA-2015:0019 "Red Hat OpenShift Enterprise 2.2.3 bug fix and enhancement update".  QE, can you verify that the defect is fixed in the latest OpenShift Enterprise 2.2 release?

Comment 2 Anping Li 2015-10-12 08:13:58 UTC
No 'warning: already initialized constant OP_TIMEOUT' was reported in /var/log/openshift/node/watchman.log.  so move bug to verified.

Comment 3 Miciah Dashiel Butler Masters 2015-10-12 14:26:48 UTC
Thanks! I'm marking this Bugzilla report CLOSED CURRENTRELEASE because the fix appears to have shipped in OpenShift Enterprise 2.2.3.


Note You need to log in before you can comment on or make changes to this bug.