Bug 1121007 - SSL errors behind proxy
Summary: SSL errors behind proxy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-setuptools
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Matej Stuchlik
QA Contact: Branislav Náter
URL:
Whiteboard:
: 1088952 (view as bug list)
Depends On:
Blocks: 1110700 1191021
TreeView+ depends on / blocked
 
Reported: 2014-07-18 06:44 UTC by mx
Modified: 2019-07-11 08:04 UTC (History)
7 users (show)

Fixed In Version: python-setuptools-0.9.8-4.el7
Doc Type: Bug Fix
Doc Text:
Due to incorrect handling of certificate validation, it was not possible for setuptools to securely download packages over a proxy server. An upstream patch has been applied, and the setuptools module now supports Secure Sockets Layer (SSL) connections over a proxy.
Clone Of:
: 1489392 (view as bug list)
Environment:
Last Closed: 2015-08-13 07:06:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1605 normal SHIPPED_LIVE python-setuptools bug fix update 2015-08-13 11:05:46 UTC

Description mx 2014-07-18 06:44:44 UTC
Description of problem:
SSL errors behind proxy

Version-Release number of selected component (if applicable):
python-setuptools-0.9.8-3.el7.noarch.rpm

How reproducible:
bash-4.2# export https_proxy=http://proxy:3128/
bash-4.2# pip install tg.devtools

Actual results:
...
    Download error on https://pypi.python.org/simple/pbr/: [Errno 1] _ssl.c:504: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol -- Some packages may not be found!
    Couldn't find index page for 'pbr' (maybe misspelled?)
    Download error on https://pypi.python.org/simple/: [Errno 1] _ssl.c:504: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol -- Some packages may not be found!
    No local packages or download links found for pbr

Expected results:
No ERROR.

Additional info:
https://bitbucket.org/pypa/setuptools/issue/52/ssl-errors-with-https-proxy
https://github.com/pypa/pip/issues/1059

Comment 2 Bohuslav "Slavek" Kabrda 2015-02-05 11:35:46 UTC
*** Bug 1088952 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2015-08-13 07:06:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1605.html


Note You need to log in before you can comment on or make changes to this bug.