Bug 1121011 - [Nagios] [RFE] - Automate configuring allowed hosts in the nrpe.cfg file and restart services required.
Summary: [Nagios] [RFE] - Automate configuring allowed hosts in the nrpe.cfg file and ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-nagios-addons
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Kanagaraj
QA Contact: RHS-C QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 06:58 UTC by RamaKasturi
Modified: 2016-04-18 10:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-21 06:44:47 UTC


Attachments (Terms of Use)

Description RamaKasturi 2014-07-18 06:58:28 UTC
Description of problem:
As of now, user has to manually go and configure allowedhosts entry in the nrpe.cfg file and restart nrpe. This whole process could be automated.

Version-Release number of selected component (if applicable):
gluster-nagios-addons-0.1.8-1.el6rhs.x86_64

How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Kanagaraj 2014-07-18 07:05:27 UTC
This is already automated when used with RHSC.

But in case where RHSC is not used, it is not possible to automate this process since we don't which RHS node is going to be nagios server.


Note You need to log in before you can comment on or make changes to this bug.