Bug 1121118 - Include /var/log/mcelog files in sosreport data collection
Summary: Include /var/log/mcelog files in sosreport data collection
Keywords:
Status: CLOSED DUPLICATE of bug 810702
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos
Version: 6.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Bryn M. Reeves
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks: 1075802
TreeView+ depends on / blocked
 
Reported: 2014-07-18 12:21 UTC by Terry Bowling
Modified: 2014-07-18 13:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-18 13:08:24 UTC


Attachments (Terms of Use)

Description Terry Bowling 2014-07-18 12:21:37 UTC
Description of problem:

Currently, the sosreport does not collect the /var/log/mcelog file as detailed in KCS https://access.redhat.com/solutions/298163

This is very useful when troubleshooting customer issues when syslog logs the following types of events:

      [Hardware Error]: Machine check events logged


This file may not exist if the mcelog service is not running, but if the file does exist, sosreport should collect it.


Version-Release number of selected component (if applicable):

sos-2.2-47.el6_5.1.noarch

Comment 2 Bryn M. Reeves 2014-07-18 13:08:24 UTC
You must be using an older version than the one specified in comment #0. This was added in 2012 in sos-2.2-28.el6:

* Fri May 18 2012 Bryn M. Reeves <bmr@redhat.com> = 2.2-28.el6
- Collect mcelog files in the hardware module
  Resolves: bz810702

commit 8bcf00e89c949504ef7dcadded5ed58d5bdde76f
Author: Bryn M. Reeves <bmr@errorists.org>
Date:   Fri May 18 11:35:58 2012 +0100

    Collect mcelog in hardware module
    Resolves: bz810702

*** This bug has been marked as a duplicate of bug 810702 ***


Note You need to log in before you can comment on or make changes to this bug.