Bug 1121170 - [TEXT] Making question about media location more clear
Summary: [TEXT] Making question about media location more clear
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 1.2.0
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ovirt-4.1.0-alpha
: ---
Assignee: Lev Veyde
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 14:31 UTC by Simone Tiraboschi
Modified: 2016-09-11 13:25 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-11 13:25:13 UTC
oVirt Team: Integration
ylavi: ovirt-4.1?
ylavi: planning_ack?
sbonazzo: devel_ack+
ylavi: testing_ack?


Attachments (Terms of Use)

Description Simone Tiraboschi 2014-07-18 14:31:41 UTC
Description of problem:

Now hosted-engine --deploy regarding the installation media for the VM asks:
 Please specify the device to boot the VM from (cdrom, disk, pxe) [cdrom]:
and choosing cdrom than asks:
 Please specify path to installation media you would like to use [None]: 

On my opinion it's now not so clear what the user should do: hosted-engine is able to have the VM booting from an iso file or from a device but it's not so clear from these questions.

I proposing to modify them this way:
 Please specify the device to boot the VM from (cdrom, iso, disk, pxe) [cdrom]:

And than, if the user choose cdrom:
 Please specify path to the cdrom device [/dev/cdrom]:
or, if the user choose iso:
 Please specify path to the iso install image [None]:



Version-Release number of selected component (if applicable):
3.5.0 beta

How reproducible:
100%

Steps to Reproduce:
1. launch hosted-engine --deploy
2.
3.

Actual results:
it asks:
 Please specify the device to boot the VM from (cdrom, disk, pxe) [cdrom]:
and choosing cdrom than asks:
 Please specify path to installation media you would like to use [None]:
and it seams not so clear

Expected results:
 Please specify the device to boot the VM from (cdrom, iso, disk, pxe) [cdrom]:
And than, if the user choose cdrom:
 Please specify path to the cdrom device [/dev/cdrom]:
or, if the user choose iso:
 Please specify path to the iso install image [None]:

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 10:58:37 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Sandro Bonazzola 2016-05-02 10:04:06 UTC
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.

Comment 3 Yaniv Lavi 2016-05-23 13:18:44 UTC
oVirt 4.0 beta has been released, moving to RC milestone.

Comment 4 Yaniv Lavi 2016-05-23 13:22:42 UTC
oVirt 4.0 beta has been released, moving to RC milestone.

Comment 5 Yaniv Lavi 2016-09-11 13:25:13 UTC
We will be removing the cdrom option in 4.1. Closing.


Note You need to log in before you can comment on or make changes to this bug.