Bug 1121173 - [start-statd] /usr/sbin/start-statd: line 8: systemctl: command not found
Summary: [start-statd] /usr/sbin/start-statd: line 8: systemctl: command not found
Keywords:
Status: CLOSED DUPLICATE of bug 1116794
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: JianHong Yin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-18 14:40 UTC by JianHong Yin
Modified: 2019-05-20 11:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-17 18:09:31 UTC


Attachments (Terms of Use)

Description JianHong Yin 2014-07-18 14:40:23 UTC
Description of problem:
[09:35:45 root@ /tmp/tmp.MCEuruJdeI]# mount -t nfs -overs=3,lock 10.12.0.78:/tmp /nfs-mount-bz566886-15640
/usr/sbin/start-statd: line 8: systemctl: command not found

Version-Release number of selected component (if applicable):
------------------------------------------------
Time & CURDIR : [2014-07-18 09:35:41 @/mnt/tests/CoreOS/nfs-utils/Regression/bz566886-start-statd-doesn-t-work-fine-while-nfslock-haven-t-been-started]
Case Name     : /CoreOS/nfs-utils/Regression/bz566886-start-statd-doesn-t-work-fine-while-nfslock-haven-t-been-started
$HOSTNAME     : intel-canoepass-01.lab.eng.rdu.redhat.com
Distro Info   : RedHatEnterpriseWorkstation 7.0 : RHEL-7.0-20140507.0
NVR & host    : Linux intel-canoepass-01.lab.eng.rdu.redhat.com 3.10.0-123.el7.x86_64 #1 SMP Mon May 5 11:16:57 EDT 2014 x86_64 x86_64 x86_64 GNU/Linux
cmdline       :
	BOOT_IMAGE=/vmlinuz-3.10.0-123.el7.x86_64 root=UUID=8b056a71-82db-4d4e-b9d4-502f3c74155a ro rd.lvm.lv=rhel_intel-canoepass-01/swap rd.lvm.lv=rhel_intel-canoepass-01/root crashkernel=auto console=ttyS0,115200n81 vconsole.font=latarcyrheb-sun16 vconsole.keymap=us
Package Info  :
	libnfsidmap-0.25-9.el7.x86_64
	package libsss_idmap is not installed
	libtirpc-0.2.4-0.3.el7.x86_64
	nfs-utils-1.3.0-0.el7.x86_64
------------------------------------------------

How reproducible:
always

Steps to Reproduce:
0. stop nfslock
1. mount -t nfs -overs=3,lock $nfsserver:$exportdir $mountpoint


Actual results:
got an error message:
/usr/sbin/start-statd: line 8: systemctl: command not found

Expected results:
-

Additional info:

Comment 2 Zdenek Pytela 2014-08-01 10:12:31 UTC
PATH variable is limited in the /usr/sbin/start-statd script to
PATH=/sbin:/usr/sbin
But systemctl is located in /usr/bin.

In addition to that, statd.service is referenced in the same script which is not present in any rpm. If rstatd.service was meant, the reference should change as well, and possibly adding rusers-server rpm as a dependency should be considered.

Duplicated bug found: 1116794

Comment 3 Steve Dickson 2014-09-17 17:21:43 UTC
commit edbbbe099bf4d4902f29d087239d6d159ac2187d
Author: Kinglong Mee <kinglongmee@gmail.com>
Date:   Fri Apr 25 10:28:47 2014 -0400

    systemd: add PATH for finding systemctl

Comment 5 Steve Dickson 2014-09-17 18:09:31 UTC

*** This bug has been marked as a duplicate of bug 1116794 ***


Note You need to log in before you can comment on or make changes to this bug.