Bug 1121191 - [vmware] cinder loses authentication with vcenter after about a one hour since started
Summary: [vmware] cinder loses authentication with vcenter after about a one hour sinc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: 5.0 (RHEL 7)
Assignee: Eric Harney
QA Contact: Jaroslav Henner
URL:
Whiteboard:
Depends On:
Blocks: 1055536 1128201
TreeView+ depends on / blocked
 
Reported: 2014-07-18 15:25 UTC by Jaroslav Henner
Modified: 2016-04-27 00:46 UTC (History)
7 users (show)

Fixed In Version: openstack-cinder-2014.1.2-2.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, problems with the VIM API retry logic resulted in stale sessions not automatically reconnecting correctly. With this update, fault handling in the session re-establishment logic has been updated to assist with session re-establishment. As a result, stale sessions can be reconnected successfully.
Clone Of:
: 1128201 (view as bug list)
Environment:
Last Closed: 2014-09-02 18:21:33 UTC


Attachments (Terms of Use)
log (65.67 KB, text/plain)
2014-07-18 15:25 UTC, Jaroslav Henner
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1129 normal SHIPPED_LIVE openstack-cinder bug fix advisory 2014-09-02 22:20:47 UTC
Launchpad 1302514 None None None Never
Launchpad 1344081 None None None Never

Description Jaroslav Henner 2014-07-18 15:25:16 UTC
Created attachment 919121 [details]
log

Description of problem:


Version-Release number of selected component (if applicable):
openstack-cinder-2014.1-7.el7ost.noarch

How reproducible:
3/3

Steps to Reproduce:
1. start cinder
2. wait 1 hour
3. cinder create --display-name vol1 1

Actual results:
voulume in ERROR

Expected results:
ACTIVE

Additional info:

Comment 1 Jaroslav Henner 2014-07-18 19:41:08 UTC
It didn't reproduce in RHOS 4.0

Comment 3 Eric Harney 2014-07-21 13:21:15 UTC
Can you post a more complete volume log showing a successful connection when the driver starts up?  I'd like to compare the two.

Comment 8 Eric Harney 2014-07-22 13:54:20 UTC
There weren't any VMware driver bugs fixed upstream in 2014.1.1 so this is probably a 2014.1 regression.

Comment 9 Stephen Gordon 2014-07-22 14:09:15 UTC
(In reply to Eric Harney from comment #8)
> There weren't any VMware driver bugs fixed upstream in 2014.1.1 so this is
> probably a 2014.1 regression.

ACK, removing blocker flag on this basis and re-targeting for GA3.

Comment 11 Jaroslav Henner 2014-07-30 10:35:14 UTC
Hi Eric, It has been resolved upstream already. Take a look.

Comment 13 Jaroslav Henner 2014-08-18 11:46:02 UTC
It didn't reproduce again and now we have much more tests running.

Comment 15 errata-xmlrpc 2014-09-02 18:21:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1129.html


Note You need to log in before you can comment on or make changes to this bug.