Bug 1121335 - unison227 is missing from epel7 repo
Summary: unison227 is missing from epel7 repo
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: unison227
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-19 12:02 UTC by Carl T. Miller
Modified: 2014-08-12 13:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-25 14:26:31 UTC


Attachments (Terms of Use)

Description Carl T. Miller 2014-07-19 12:02:34 UTC
Description of problem:
unison227 is missing from epel7 repo

Version-Release number of selected component (if applicable):
unison version 2.27

How reproducible:
every time

Steps to Reproduce:
1.  yum -y install unison227
2.
3.

Actual results:
No package unison227 available.

Expected results:
Package would be installed.

Additional info:
epel7 repo is still in beta, and I need unison227 before I can adopt el7

Comment 1 Tim Jackson 2014-07-23 13:42:14 UTC
I am not planning to build this for EL-7. If anyone would like to take ownership of the EL-7 branch, feel free.

Comment 2 Carl T. Miller 2014-07-25 13:21:43 UTC
Please explain why this was closed.  My understanding is that this is the place to report missing packages.

Tim, I understand that you might not want to support this, but please leave it open until there is a resolution.

Comment 3 Richard W.M. Jones 2014-07-25 13:27:17 UTC
I think Tim explained quite well why there is no package in EPEL 7.
If you want it, please become a package maintainer and you can
add the package yourself:

https://fedoraproject.org/wiki/EPEL_Package_Maintainers#Joining_the_EPEL_Package_Maintainers

Comment 4 Carl T. Miller 2014-07-25 13:39:34 UTC
Thanks for responding, Richard.  I didn't think Tim explained it at all.  Basically he said that he won't support it, and then he closed it without comment.

My suggestion would be to leave this open, since closing the ticket would prevent others from being aware that the package is apparently orphaned.

If I'm missing something about how to properly report problems with EPEL, please point me to a URL that explains how to properly use bugzilla for EPEL.

Comment 5 Richard W.M. Jones 2014-07-25 13:47:03 UTC
The package is not "orphaned".  Tim is quite free to support or
not support branches as he feels he is able.  Filing a bug doesn't
ring a light somewhere assigning someone to fix your problem.  If
he doesn't want to support EPEL, then the fastest way to get a fix
is for *you* to step up and do the work.

Comment 6 Carl T. Miller 2014-07-25 13:52:31 UTC
Aha.  I thought the purpose of bugzilla was to ring bells.

Since I don't have what it takes to create/maintain the package, is there a better place for me to make the request?

Comment 7 Richard W.M. Jones 2014-07-25 14:04:13 UTC
There is no such place to get someone to package this for free.
You will have to read the link I posted above.

Comment 8 Carl T. Miller 2014-07-25 14:26:31 UTC
Got it.  Thanks for the explaination.  I'll close the ticket now that this has been explained.

Comment 9 Carl T. Miller 2014-08-12 13:04:41 UTC
In case anyone finds this report and needs unison working,
I found a temporary solution.  Download the unison227 rpm
file for fedora 17 and install it.


Note You need to log in before you can comment on or make changes to this bug.