Bug 1121648 - even if you uncheck the "Open in Full Screen" checkbox, console opens in full screen.
Summary: even if you uncheck the "Open in Full Screen" checkbox, console opens in full...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal
Version: 3.4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Frantisek Kobzik
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 13:25 UTC by Pratik Pravin Bandarkar
Modified: 2019-10-10 09:24 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-04 08:19:44 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Pratik Pravin Bandarkar 2014-07-21 13:25:04 UTC
Description of problem:
From user portal basic view, I can see the "Open in Full Screen" option is ticked by default in RHEV 3.4. 
---
From user portal --> Basic tab --> select vm --> click on SPICE(Edit) --> "Open in Full Screen" option is checked
---

But, even if you uncheck the "Open in Full Screen" checkbox, console opens in full screen.


Version-Release number of selected component (if applicable):
RHEV3.4

How reproducible:
100%

Steps to Reproduce:
1. go to user portal(basic view) and uncheck "Open in Full Screen" option for any vm. 
2. open console.

Actual results:
console opens in full screen even if we uncheck  "Open in Full Screen" option.

Expected results:
console should not open in full screen mode if we uncheck  "Open in Full Screen" option.

Additional info:
same behavior observed in extended view as well. i.e. even if "Open in Full Screen" checkbox is unchecked, console opens in full screen.

Comment 1 Michal Skrivanek 2014-07-22 08:09:19 UTC
is vdagent running fine and qxl drivers are installed?

you use .vv file or plugin? Please attach a .vv file for both states of the fullscreen checkbox (and if you used plugin please switch to native and verify the behavior)

Comment 2 Pratik Pravin Bandarkar 2014-07-22 11:19:21 UTC
(In reply to Michal Skrivanek from comment #1)
> is vdagent running fine and qxl drivers are installed?
Getting same behaviour for windows as well as rhel vm. 

From RHEL vm:

[root@dhcp210-44 ~]# /etc/init.d/spice-vdagentd status
spice-vdagentd (pid  1446) is running...

[root@dhcp210-44 ~]# rpm -ql xorg-x11-drv-qxl
/usr/lib64/xorg/modules/drivers/qxl_drv.so
/usr/share/doc/xorg-x11-drv-qxl-0.1.0
/usr/share/doc/xorg-x11-drv-qxl-0.1.0/COPYING
/usr/share/doc/xorg-x11-drv-qxl-0.1.0/README


> 
> you use .vv file or plugin? Please attach a .vv file for both states of the
> fullscreen checkbox (and if you used plugin please switch to native and
> verify the behavior)

ok. It was set to "Auto". After changing it to "Native" its working as expected(from basic/extended view). i.e. console do not opens in full screen if "Open in Full Screen" checkbox is unchecked.

Issue only occurs if "Console Invocation" is set to "Auto"/"Browser Plugin".

Comment 3 Frantisek Kobzik 2014-07-25 13:04:05 UTC
So I just tried and couldn't reproduce.
My environment:
RHEV-M 3.4.0-0.21.el6ev
Clients:
1, Win7 32-bit, IE 11, spice active-x plugin 5.0.3.4004
2, Fedora 20, Firefox 26, spice-xpi-2.8.90-1.fc20.x86_64

In both clients I created 2 VMs in extended user portal (one windows vm, one OS-less vm). 

In Console Options dlg, state of checkboxes was ok (checked in eUP, unchecked in bUP).

Spice client (tried both Plugin and Native execution) started in fullscreen if and only if when checkbox was checked.

Comment 4 Frantisek Kobzik 2014-07-25 13:05:47 UTC
What versions of spice clients (active-x/xpi, virt-viewer application) did you reproduce this bug on?

Comment 5 Michal Skrivanek 2014-08-25 12:00:34 UTC
ping?

Comment 6 Pratik Pravin Bandarkar 2014-09-03 17:57:24 UTC
(In reply to Frantisek Kobzik from comment #3)
> So I just tried and couldn't reproduce.
> My environment:
> RHEV-M 3.4.0-0.21.el6ev
> Clients:
> 1, Win7 32-bit, IE 11, spice active-x plugin 5.0.3.4004
> 2, Fedora 20, Firefox 26, spice-xpi-2.8.90-1.fc20.x86_64
> 
> In both clients I created 2 VMs in extended user portal (one windows vm, one
> OS-less vm). 
> 
> In Console Options dlg, state of checkboxes was ok (checked in eUP,
> unchecked in bUP).
> 
> Spice client (tried both Plugin and Native execution) started in fullscreen
> if and only if when checkbox was checked.

Sorry for delay in reply. The setup where I reproduced the issue is gone(I destoryed it few days back). So, I tested on another rhev3.4 setup and now I am unable to reprodcue the issue :(  So, I guess we can close the bug.

Comment 7 Frantisek Kobzik 2014-09-04 08:19:44 UTC
Ok, thanks.


Note You need to log in before you can comment on or make changes to this bug.