Bug 1121719 - no sound from Intel hda 82801I (ICH9 Family) with kernel 3.15.5 and 3.15.6
Summary: no sound from Intel hda 82801I (ICH9 Family) with kernel 3.15.5 and 3.15.6
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 17:23 UTC by Ionut Radu
Modified: 2014-08-17 09:22 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-17 09:22:02 UTC


Attachments (Terms of Use)
dmesg for kernel 3.15.6 (69.94 KB, text/x-log)
2014-07-21 17:23 UTC, Ionut Radu
no flags Details
dmesg for kernel 3.14.8 (69.16 KB, text/x-log)
2014-07-21 17:24 UTC, Ionut Radu
no flags Details
lspci for kernel 3.15.6 (8.87 KB, text/x-log)
2014-07-21 17:25 UTC, Ionut Radu
no flags Details


Links
System ID Priority Status Summary Last Updated
Linux Kernel 81751 None None None Never

Description Ionut Radu 2014-07-21 17:23:35 UTC
Created attachment 919702 [details]
dmesg for kernel 3.15.6

Description of problem:
There is no sound with kernel 3.15.5 and 3.15.6

Version-Release number of selected component (if applicable):
3.15.5
3.15.6

How reproducible:
Always

Steps to Reproduce:
1. Boot 3.15.5 or 3.15.6 kernel
2.
3.

Actual results:
No sound.

Expected results:
Sound should be ok.

Additional info:
With kernel 3.14.8 there is no problem

Comment 1 Ionut Radu 2014-07-21 17:24:17 UTC
Created attachment 919703 [details]
dmesg for kernel 3.14.8

Comment 2 Ionut Radu 2014-07-21 17:25:04 UTC
Created attachment 919704 [details]
lspci for kernel 3.15.6

Comment 3 Ionut Radu 2014-07-23 09:02:14 UTC

It looks like HDA intel audio is incorrectly detected as Conexant CX20561

[   15.060156] sound hdaudioC0D2: CX20561 (Hermosa): BIOS auto-probing.
[   15.060614] sound hdaudioC0D2: autoconfig: line_outs=1 (0x1a/0x0/0x0/0x0/0x0) type:speaker
[   15.060618] sound hdaudioC0D2:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   15.060620] sound hdaudioC0D2:    hp_outs=1 (0x16/0x0/0x0/0x0/0x0)
[   15.060623] sound hdaudioC0D2:    mono: mono_out=0x0
[   15.060625] sound hdaudioC0D2:    inputs:
[   15.060628] sound hdaudioC0D2:      Internal Mic=0x1d
[   15.060630] sound hdaudioC0D2:      Mic=0x18
[   15.061311] sound hdaudioC0D2: Enable sync_write for stable communication

Comment 4 Ionut Radu 2014-08-09 07:56:01 UTC
It turned out to be a PulseAudio bug which wrongly detects headphone as plugged-in and set Speaker Volume to 0% and Headphone Volume to 100%

Comment 5 Rex Dieter 2014-08-09 19:28:43 UTC
If so, I'd strongly suggest taking this upstream to bugzilla.freedesktop.org pulseaudio component.

Comment 6 Ionut Radu 2014-08-09 19:34:18 UTC
I'm not sure yet if it's PulseAudio bug or alsa bug. PulseAudio gets a notification from alsa about headphone plugged-in or unplugged. Maybe the notifications from alsa are not good.

Comment 7 Ionut Radu 2014-08-17 09:22:02 UTC
It solved itself.


Note You need to log in before you can comment on or make changes to this bug.