Bug 1121754 - Upgrading python-django-horizon breaks sahara dashboard component configuration
Summary: Upgrading python-django-horizon breaks sahara dashboard component configuration
Keywords:
Status: CLOSED DUPLICATE of bug 1177832
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-sahara
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: RHOS Maint
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 19:18 UTC by Luigi Toscano
Modified: 2015-03-27 16:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-27 16:47:17 UTC


Attachments (Terms of Use)

Description Luigi Toscano 2014-07-21 19:18:48 UTC
Description of problem:
Sahara dashboard configuration touches both 
/etc/openstack-dashboard/local_settings and 
/usr/share/openstack-dashboard/openstack_dashboard/settings.py

While local_settings is preserved upon upgrade (.rpmnew is created if not existigs), settings.py is not, so saharadashboard configuration is lost.

Version-Release number of selected component (if applicable):
python-django-horizon-2014.1.1-2
python-django-sahara-2014.1.1-1
(upgrading from the previously released:
python-django-horizon-2014.1-7
python-django-sahara-2014.1.0-3 )

How reproducible:
Install and configure saharadashboard according:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/5/html-single/Installation_and_Configuration_Guide/index.html#Install_the_OpenStack_Sahara_User_Interface

Upgrade python-django-horizon.


Actual results:
Sahara dashboard disappears.

Expected results:
Sahara dashboard still works.

Additional info:

Comment 2 Tomas Rusnak 2014-07-22 09:08:48 UTC
Confirmed with packages:

openstack-dashboard-2014.1-7.el7ost.noarch.rpm
python-saharaclient-0.7.0-3.el7ost.noarch
openstack-sahara-2014.1.1-2.el7ost.noarch
python-django-sahara-2014.1.1-1.el7ost.noarch

As I understand it, it's a problem with openstack-dashboard package. After it's upgrade, the sahara settings from /usr/share/openstack-dashboard/openstack_dashboard/settings.py are lost.

As you can see from yum update, only local_settings file was preserved:

 Updating   : openstack-dashboard-2014.1.1-2.el7ost.noarch                                                     15/112 
warning: /etc/openstack-dashboard/local_settings created as /etc/openstack-dashboard/local_settings.rpmnew

Comment 3 Elise Gafford 2015-03-27 16:47:17 UTC

*** This bug has been marked as a duplicate of bug 1177832 ***


Note You need to log in before you can comment on or make changes to this bug.