Bug 1121766 - Profile Configuration Tab does not refresh properly with OProfile
Summary: Profile Configuration Tab does not refresh properly with OProfile
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: DevTools
Classification: Red Hat
Component: rh-eclipse47
Version: rh-eclipse47
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 2018.1
Assignee: Roland Grunberg
QA Contact: Martin Cermak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 19:55 UTC by Roland Grunberg
Modified: 2018-01-04 21:18 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-04 21:18:47 UTC


Attachments (Terms of Use)

Description Roland Grunberg 2014-07-21 19:55:46 UTC
From Bug 1116387

> > - create new profile configuration with oprofile, uncheck "Use default event"
> > checkbox, select CPU_CLK_UNHALTED (I use often virtual machines...).
> > - Apply, Profile, profiling works like a charm
> >
> > Then...
> >
> > - open profiling configurations, select the same one, Profiler tab, Events
> tab:
> > "Use default event" is unchecked, Counter tab is empty
> > - if I click on Profile button to perform profiling, it starts and runs fine
> (as
> > far as I can tell)
> > - if I click on "Use default events", Counter tab gets filled and is grayed
> out
> > to sign me that it's not enabled, which is in fact correct, because "Use
> default
> > event" box is now checked. Unchecking "Use default event" makes Counter tab
> > available and I'm able to select events.
> 
> I've been able to reproduce this particular issue as well. This would appear to
> be https://bugs.eclipse.org/bugs/show_bug.cgi?id=436655 . For the "Profile
> Configurations" dialog, we have a combo box that lists various profiling
> launches (perf, oprofile, massif, etc.) and once selected, will change the tabs
> as required. We call layout() to redraw the newly loaded tabs and this seems to
> be an issue on GTK3.  Note that if you go to Profiling Tools -> Profiling Tools
> Configurations (instead of Profile As -> Profile Configurations) and then create
> a "Profile With OProfile" and do the same as before, the Events Tab will be draw
> as expected (we don't call layout() here) . Furthermore adding the 2 lines :
> 
> '--launcher.GTK_version' and '2' right below 'openFile' in
> /opt/rh/devtoolset-3/root/etc/eclipse.ini also fixes the issue. In addition,
> because the problem is with GTK3, this behaviour shouldn't be happening on RHEL
> 6 (has GTK 2).
> 
> I'm aware of some work being done by Alex to try and resolve this but I'm also
> looking into any way of avoiding that layout() call.

Comment 6 Alexander Kurtakov 2015-08-28 11:34:46 UTC
No resources for fixing this. Postponing.

Comment 7 Alexander Kurtakov 2016-04-20 13:23:28 UTC
Roland, would you please check whether this bug is fixed?

Comment 8 Roland Grunberg 2016-04-25 16:38:25 UTC
I think this might still be an issue. I haven't tested against Oprofile yet but the same type of problem also exists against the Callgraph options.

Comment 9 Mat Booth 2016-04-27 23:15:23 UTC
Okay, thanks for looking.

Comment 10 Roland Grunberg 2017-06-15 20:00:34 UTC
According to the upstream bug, this should have been fixed in Eclipse (Neon) 4.6M3. I think the last time we tested this out, it would have been against 4.5 (Mars).

I could try testing this out, and if the report is correct, we can mark this as having been fixed upstream, and as a result, fixed in our new release channel.

Comment 11 Alexander Kurtakov 2017-12-08 05:50:00 UTC
Roland, please verify this is fixed and act according to the results on this bug.

Comment 12 Roland Grunberg 2018-01-04 21:09:20 UTC
I just tried this out but was unable to reproduce. That is, after profiling a simple C application with CPU_CLK_UNHALTED, and going back to the profile configuration for OProfile, under Events, the Counter tab is fully visible and other events may be seen. Does it make sense to mark this as CLOSED (UPSTREAM) ?

Comment 13 Roland Grunberg 2018-01-04 21:18:47 UTC
Marking as CLOSED (UPSTREAM). This was very likely fixed by https://bugs.eclipse.org/bugs/show_bug.cgi?id=470129 (Eclipse Neon, 4.6M3). https://bugs.eclipse.org/bugs/show_bug.cgi?id=436655 was basically a duplicate of that one.


Note You need to log in before you can comment on or make changes to this bug.