Bug 1121767 - Output from lvmdiskscan misleading
Summary: Output from lvmdiskscan misleading
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Logical_Volume_Manager
Version: 7.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Steven J. Levine
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 19:59 UTC by Ricky Ayoub
Modified: 2019-03-06 02:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-05 20:07:38 UTC


Attachments (Terms of Use)

Description Ricky Ayoub 2014-07-21 19:59:45 UTC
Description of problem:
In "4.2.1.3 Scanning for Block Devices" the example output shown for lvmdiskscan, the indentation order makes it look as if the other devices are a subset of /dev/ram0.

Actual results:
# lvmdiskscan
/dev/ram0                    [       16.00 MB]
  /dev/sda                     [       17.15 GB]
  /dev/root                    [       13.69 GB]
  /dev/ram                     [       16.00 MB]
  /dev/sda1                    [       17.14 GB] LVM physical volume


Expected results:
# lvmdiskscan
  /dev/ram0                    [       16.00 MB]
  /dev/sda                     [       17.15 GB]
  /dev/root                    [       13.69 GB]
  /dev/ram                     [       16.00 MB]
  /dev/sda1                    [       17.14 GB] LVM physical volume


Additional info
In the PDF version of the documentation, there appear to be other alignment issues with this block of text that aren't present when running the actual command.

Comment 3 Steven J. Levine 2014-10-24 21:25:14 UTC
I have fixed the alignment in the original page. The alignment is fine in the html version. I don't know what the problem is in the pdf version but it seems to be a bug in the pdf printing. I'll check into that, but I'm not sure what can be done from my end.

In the meantime, I fixed the spacing alignment issue so I'm putting this bug in MODIFIED for now.

Comment 4 Steven J. Levine 2014-10-24 21:26:47 UTC
That is: I've fixed the spacing alignment issue in the working 7.1 draft. It should be on the public site for the 7.1 beta.


Note You need to log in before you can comment on or make changes to this bug.