Bug 1121785 - ath3k firmware load fails with kernels > kernel-3.15.3-200.fc20.x86_64, fine with 3.14.x kernels
Summary: ath3k firmware load fails with kernels > kernel-3.15.3-200.fc20.x86_64, fine ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1118472 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-21 21:14 UTC by T
Modified: 2014-08-04 23:30 UTC (History)
8 users (show)

Fixed In Version: kernel-3.15.7-200.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-01 06:02:34 UTC


Attachments (Terms of Use)

Description T 2014-07-21 21:14:45 UTC
Description of problem:

bluetooth adapter no longer usable after kernel update from 3.14.9 to 3.15.3 -- 3.15.6

Version-Release number of selected component (if applicable):

Fedora 20 x86_64

How reproducible:


Steps to Reproduce:
1. boot stock fedora kernel > 3.14.9
2. boot message:
Jul 20 23:59:51  kernel: Bluetooth: Can't get version to change to load ram patch err
Jul 20 23:59:51  kernel: Bluetooth: Loading patch file failed
Jul 20 23:59:51  kernel: ath3k: probe of 1-1.1:1.0 failed with error -110

3. bluetooth adaptor not usable

Actual results:

bluetooth does not work

Expected results:

bluetooth should work, as it does with a kernel < 3.15

Additional info:

this is a know bug: https://bugzilla.kernel.org/show_bug.cgi?id=73981

why isn't it patched in one of the several kernel updates in the past 3 weeks?

Thanks
T.

Comment 1 Alex. H. F. 2014-07-23 20:31:24 UTC
I have same problem.

My bluetooth device is the following:
$ lsusb
Bus 002 Device 007: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth

dmesg output:
dmesg | grep -A10 0cf3
[31964.167714] usb 2-1.2: new full-speed USB device number 8 using ehci-pci
[31964.253267] usb 2-1.2: New USB device found, idVendor=0cf3, idProduct=3000
[31964.253276] usb 2-1.2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[31964.605213] usb 2-1.2: USB disconnect, device number 8
[31965.776954] usb 2-1.2: new full-speed USB device number 9 using ehci-pci
[31965.862898] usb 2-1.2: New USB device found, idVendor=0cf3, idProduct=3005
[31965.862907] usb 2-1.2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[31970.861422] Bluetooth: Can't get version to change to load ram patch err
[31970.861433] Bluetooth: Loading patch file failed
[31970.861487] ath3k: probe of 2-1.2:1.0 failed with error -110

Can't understand why it "finds" the device twice, first as PID:3000, than PID:3005...

As T. mentions there is this entry at kernel-buzilla yet:
https://bugzilla.kernel.org/show_bug.cgi?id=73981

As we can see, there might be a patch available, but I am not sure if it will solve the issue regarding to my device VID:0cf3/PID:3005.

Could anyone please answer this question?

Further, is there a way the workaround the problem? Maybe (re)loading the the correct driver, and bring my device to work 'by hand' for the moment?

Comment 2 Josh Boyer 2014-07-24 12:40:08 UTC
(In reply to T from comment #0)
> Description of problem:
> 
> bluetooth adapter no longer usable after kernel update from 3.14.9 to 3.15.3
> -- 3.15.6
> 
> Version-Release number of selected component (if applicable):
> 
> Fedora 20 x86_64
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1. boot stock fedora kernel > 3.14.9
> 2. boot message:
> Jul 20 23:59:51  kernel: Bluetooth: Can't get version to change to load ram
> patch err
> Jul 20 23:59:51  kernel: Bluetooth: Loading patch file failed
> Jul 20 23:59:51  kernel: ath3k: probe of 1-1.1:1.0 failed with error -110
> 
> 3. bluetooth adaptor not usable
> 
> Actual results:
> 
> bluetooth does not work
> 
> Expected results:
> 
> bluetooth should work, as it does with a kernel < 3.15
> 
> Additional info:
> 
> this is a know bug: https://bugzilla.kernel.org/show_bug.cgi?id=73981
> 
> why isn't it patched in one of the several kernel updates in the past 3
> weeks?

Because it wasn't known by anyone doing the updates.  Thanks for filing the bug.

Comment 3 Josh Boyer 2014-07-24 14:28:04 UTC
Patch added in Fedora git.

Comment 4 Josh Boyer 2014-07-26 02:26:44 UTC
*** Bug 1118472 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2014-07-29 03:56:28 UTC
kernel-3.15.7-200.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.15.7-200.fc20

Comment 6 Fedora Update System 2014-07-30 07:03:46 UTC
Package kernel-3.15.7-200.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.15.7-200.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9010/kernel-3.15.7-200.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-08-01 06:02:34 UTC
kernel-3.15.7-200.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 T 2014-08-04 23:30:16 UTC
I confirm that this is fixed with kernel 3.15.7-200.fc20.x86_64

Thanks a lot
T.


Note You need to log in before you can comment on or make changes to this bug.